Android phones and tablets stuck in USB "charging" mode can't select MTP mode!

Discussion in 'Mavic Pro Discussions' started by Mr Spock, Nov 26, 2016.

  1. Mr Spock

    Mr Spock Well-Known Member

    Joined:
    Nov 19, 2016
    Messages:
    142
    Likes Received:
    33
    Is there any way to stop android devices charging when using the controller? I tried changing the USB connection settings and tried USB debug mode but every time i manualy select MTP mode it just reverts at "charging" mode. Everything works fine so there is video and data conactivity with the controller but the phone just drains the controller's battery. I get at around 65 to 50% battery just with one 20min flight.
    I tested the following devices:
    Samsung S7 edge, S6 edge+, Tab S2, Huawei media pad. Same problem all of them.
    Is there something i am missing in the android devices or controller settings?
     
  2. Kilrah

    Kilrah Well-Known Member

    Joined:
    Nov 12, 2016
    Messages:
    998
    Likes Received:
    350
    Location:
    Switzerland
    No, all android devices charge as soon as connected, no choice. MTP would charge as well BTW.

    I managed to make my Huawei Mate 8 stop drawing power from USB, but it requires rooting and whether it's possible to disable it and the method to do so are different for every device.
     
  3. Mr Spock

    Mr Spock Well-Known Member

    Joined:
    Nov 19, 2016
    Messages:
    142
    Likes Received:
    33
    How do you do rooting ?

    Sent from my SM-G935F using MavicPilots mobile app
     
  4. Kilrah

    Kilrah Well-Known Member

    Joined:
    Nov 12, 2016
    Messages:
    998
    Likes Received:
    350
    Location:
    Switzerland
    Different for each device. Just google "[your device] root". Note that it may void your device's warranty and/or disable features permanently (particularly on Samsung devices).
     
    KR FlyingPhotos.ca likes this.
  5. Mavic

    Mavic Well-Known Member

    Joined:
    Oct 12, 2016
    Messages:
    55
    Likes Received:
    17
    When rooted install the app " disable USB charging". You will find it in the Google play store (free)

    __
     
    #5 Mavic, Nov 27, 2016
    Last edited by a moderator: Dec 5, 2016
  6. sdharris

    sdharris Well-Known Member

    Joined:
    Oct 12, 2016
    Messages:
    154
    Likes Received:
    54
    Before you root your phone understand the consequences and make sure its worth it for the relatively short amount of time you use your phone for flying compared with normal daily use.
     
    RobertD, John and Kilrah like this.
  7. Mr Spock

    Mr Spock Well-Known Member

    Joined:
    Nov 19, 2016
    Messages:
    142
    Likes Received:
    33
    So with rooting u can disable charging for the dji go app only when the phone is connected to the rc?
    Is this a bug that DJI has to fix with a controller FW?
    What i will do for now is disable fast charging though thats easy.


    Sent from my SM-G935F using MavicPilots mobile app
     
  8. Kilrah

    Kilrah Well-Known Member

    Joined:
    Nov 12, 2016
    Messages:
    998
    Likes Received:
    350
    Location:
    Switzerland
    Note that this only works with some devices. It doesn't with either of the 2 I use.

    You MAY be able to disable USB charging altogether, with SOME devices. Nothing specific to the GO app.

    No, it's just how Android phones work. DJI can't do much about it.
     
  9. Mr Spock

    Mr Spock Well-Known Member

    Joined:
    Nov 19, 2016
    Messages:
    142
    Likes Received:
    33
    Why they (DJI) don't modify the short USB cable by disabling the red wire? Someone suggested i do that.
     
  10. Kilrah

    Kilrah Well-Known Member

    Joined:
    Nov 12, 2016
    Messages:
    998
    Likes Received:
    350
    Location:
    Switzerland
    Because that likely won't work, most phones use it as "something is connected" indication, if you cut the red wire you may never have any connection.
     
    Mr Spock likes this.
  11. Radioflyers

    Radioflyers Member

    Joined:
    Feb 2, 2017
    Messages:
    21
    Likes Received:
    5
    Location:
    New Port Richey, FL
    My Samsung Tab E 8" worked for many flights then developed this charge only state disabling the connection. Could this just be a USB cable issue?
     
  12. msinger

    msinger Well-Known Member
    Approved Vendor

    Joined:
    Oct 12, 2016
    Messages:
    4,384
    Likes Received:
    1,814
    Location:
    Harrisburg, PA
    If you swipe down from the top of the screen, you can change the USB configuration. When it's set to charging, you won't be able to connect your mobile device to DJI GO.
     
  13. Radioflyers

    Radioflyers Member

    Joined:
    Feb 2, 2017
    Messages:
    21
    Likes Received:
    5
    Location:
    New Port Richey, FL
    I tried all the options but still no luck with connection. Switched to my Samsung S6 using the left side connector on the RC and all worked fine.
     
  14. Radioflyers

    Radioflyers Member

    Joined:
    Feb 2, 2017
    Messages:
    21
    Likes Received:
    5
    Location:
    New Port Richey, FL
    After trying 3 different USB to micro USB and a lightening cable to an iPad I realized I still had a short micro USB plugged into the top left of my he the RC.
    Now all works as normal with any cable.
     
  15. Radioflyers

    Radioflyers Member

    Joined:
    Feb 2, 2017
    Messages:
    21
    Likes Received:
    5
    Location:
    New Port Richey, FL
    Make sure you only use one of the two possible phone or tablet connections or the RC full size USB will only charge.
     
Loading...
Similar Threads - Android phones tablets Forum Date
Go back to using Google Maps on DJI Go/DJI Go 4 for Rooted Android Phones Mavic Pro Discussions Jan 19, 2017
Screen sharing android to Windows 10 Control Apps - DJI, Litchi, Autopilot, etc... Monday at 11:27 AM
Android Tablet with 4G LTE for Mavic? Mavic Pro Discussions Mar 22, 2017
How can I change the Facebook Live account in dji go 4 Android? Classifieds Mar 20, 2017
Best Android Tablet for DJI Go 4 Mavic Pro Discussions Mar 19, 2017

Share This Page