Welcome Mavic Pilot!
Jump in and join our free DJI Mavic community today!
Sign up

Davinci Resolve very choppy/laggy

Rivendell

Well-Known Member
Joined
Mar 6, 2018
Messages
45
Likes
10
Age
52
#1
I am a relative noobie but have bought a gaming computer, with an award for video editing, on which I have downloaded Davinci Resolve 14 (free version). I have followed various YouTube videos to get me started but the playback within the programme is really laggy and choppy The rendered product is better, but not as good as the buttery smooth playback of the 4K when played through Windows media player.

The computer is a Dell Inspiron 15 7577. This is 7th generation i7 with 16GB of RAM and a 1050Ti graphics card.

My wife has a MacBook Pro with an older processor and a pretty basic graphics card (it's about 4 years old) and editing identical MP clips through DR is far smoother. I have compared all the project settings for both computers and ensured they are identical.

This is doing my head in - I can't see any reason for it. Any ideas please? I must be doing something wrong ....
 

Fmoots

Well-Known Member
Joined
Jan 29, 2018
Messages
100
Likes
62
Age
33
#2
Davinchi resolve is not as well optimised as some other editing programs for playing & scrubbing through 4k footage, although it has been vastly improved with recent updates.

It's always better to edit with proxy files when editing 4k footage (unless you have a very powerful machine). Proxy files are basically downres'd versions of your straight out of camera files. It also changes the codec since straight out of camera h264 are highly compressed and do not play back very well - compared to say Prores.

This allows you to work with downres's files and give you a much smoother editing experience. The files are only downres' for editing purposes and when you render out your final project it will be full resolution again.

To create proxy files right click on your clips and select 'create optimised media'. Also ensure you have 'Use optimised media when available' checked at the top. Remember to uncheck this before rendering. You can change what resolution you want the optimised media to be in the settings. I'd probably recommend 1/2 or 1/4 quality if you're shooting in 4k.

There isn't really any need to edit in native 4k unless you have a second 4k display in front of you and you want to see your 4k project in real time. The best workflow is probably - import 4k mavic files - create optimised media to downres to 1/2 or 1/4 quality - edit at this quality - render out your final project at 4k

Also is your timeline 4k or 1080? I'd recommend making your timeline 1080p and then you can always change it back to 4k before rendering. Editing on a 4k will give you a much smoother experience in Davinchi
 

Lake_Flyer

Well-Known Member
Joined
Jun 8, 2017
Messages
1,139
Likes
599
Age
61
#3
Great advice from Fmoots here.

Another thing is to check your Windows. When I updated to Resolve 14 it ran very smooth, even with a 4K timeline, no optimised media and full res edit view. I use a Dell i7 XPS with 16G and a RX550 4G videocard, so nothing really that powerful. However, after a few recent windows updates things started to become extremely choppy in Resolve. The rendered files also had anomalies and weren't useable. I uninstalled the Windows updates from the last 2 months and did a fresh cumulative. After that a fresh install of the video card drivers. Problem solved, just as smooth as before. Took me a couple of days to find out though. But I read somewhere that people were getting problems with there video cards after certain updates so that got me started.
 

Rivendell

Well-Known Member
Joined
Mar 6, 2018
Messages
45
Likes
10
Age
52
#4
Thanks Fmoots and Lake_Flyer. The free version doesn't allow editing or timeline at 4K, so it defaults to 1080. Image optimisation is available, but it repeatedly comes up with an "Error" message. I have uninstalled it and will try a reinstall later tonight. I'll then have another go at editing over the weekend. My real frustration is that the very machine I thought wouldn't be up to the job (old Mac Book) is doing a fine job and the brand new 'ultra quick' gaming machine is making heavy weather of it. I will pursue the Davinci root as it's well recommended here and elsewhere, but am already considering paying a few quid for CyberLink Power Director 16!
 

BaNZ

Well-Known Member
Joined
Mar 28, 2018
Messages
94
Likes
24
#6
I'm on i5-6600k 3.5Ghz 16GB and Nvidia 1070. The suggestions provided here are good. I also had lagging performance when editing the timeline or clips at 4K. I started using optimized media and that fixed the problem.
 

Fmoots

Well-Known Member
Joined
Jan 29, 2018
Messages
100
Likes
62
Age
33
#7
Thanks Fmoots and Lake_Flyer. The free version doesn't allow editing or timeline at 4K, so it defaults to 1080. Image optimisation is available, but it repeatedly comes up with an "Error" message. I have uninstalled it and will try a reinstall later tonight. I'll then have another go at editing over the weekend. My real frustration is that the very machine I thought wouldn't be up to the job (old Mac Book) is doing a fine job and the brand new 'ultra quick' gaming machine is making heavy weather of it. I will pursue the Davinci root as it's well recommended here and elsewhere, but am already considering paying a few quid for CyberLink Power Director 16!
The free version should allow 4k timelines? I have the free version myself and I have this option. Click on the cog in the bottom right then under master settings select 'master settings' and then 'timeline resolution.

I'm surprised it is struggling on a 1050ti is struggling, maybe try upgrading your GPU drivers?
 

Rivendell

Well-Known Member
Joined
Mar 6, 2018
Messages
45
Likes
10
Age
52
#8
Thanks again Fmoots. I have now reloaded the Davinci software and am able to create optimised files. However, if I import a 4K clip of, say, 5 minutes length it takes around an hour to optimise it!!! Is that right? I suppose it's stripping the file back to raw and rebuilding it into something it feels it can work with, but I don't have the time (or inclination) to have to go through that process every time. Am I missing something?
 

Lake_Flyer

Well-Known Member
Joined
Jun 8, 2017
Messages
1,139
Likes
599
Age
61
#9
Thanks again Fmoots. I have now reloaded the Davinci software and am able to create optimised files. However, if I import a 4K clip of, say, 5 minutes length it takes around an hour to optimise it!!! Is that right? I suppose it's stripping the file back to raw and rebuilding it into something it feels it can work with, but I don't have the time (or inclination) to have to go through that process every time. Am I missing something?
After reading this thread I tried another edit yesterday in Resolve 14 (free version) with a 4K timeline, no optimised media, full resolution edit preview. Smooth! Only full screen playback while in the color edit mode gives some stutter. And this is with a medium class video card (Radeon RX550, which is an amazing bang for the buck). Seriously, only my windows settings happened to be screwed up after a flawed windos security update.

Having to make optimised media first, for every clip you want to quickly cut and edit, is not doable. It takes forever. I would only do that for a real complex job, in which case I would have Resolve first do all the optimising before even beginning to edit, which could take a full day/night.
 

Lake_Flyer

Well-Known Member
Joined
Jun 8, 2017
Messages
1,139
Likes
599
Age
61
#10
However, if I import a 4K clip of, say, 5 minutes length it takes around an hour to optimise it!!! Is that right?
That's quite normal.
 

Rivendell

Well-Known Member
Joined
Mar 6, 2018
Messages
45
Likes
10
Age
52
#11
Thanks Lake_Flyer. When I watch the timeline it continuously stutters. I will get a couple of seconds of smooth video and then a freeze for a second and then a jump to wherever the timeline is in real time. It's impossible to scrub accurately. I recorded some footage yesterday at 1080 and this runs as smooth as silk. I inserted a 4K clip immediately after it in the timeline and on playback the stuttering started immediately on transition from the 1080 to the 4K. My graphics card is a NVIDI® GeForce® GTX 1050 Ti with 4GB GDDR5 graphics memory.
Unfortunately I'm not particularly savvy at doing deeper diagnostics. I have run a simple diagnosis using the standard Windows maintenance software and all seems Ok. I reiterate that things are just fine on an old MacBook we have (and I'm not an Apple fanatic). I really appreciate the help.
 

Lake_Flyer

Well-Known Member
Joined
Jun 8, 2017
Messages
1,139
Likes
599
Age
61
#13
And what happens if you import a 4K clip but set the timeline to 1080p? Before rendering you just set it back to 4K.
 

Rivendell

Well-Known Member
Joined
Mar 6, 2018
Messages
45
Likes
10
Age
52
#14
I'll run more checks through the day. I'll find a way to test the graphics card performance. Good news is that the optimised 4K image runs smooth as silk in the timeline. However, this doesn't seem a practical solution for routine editing. More to follow.
 

Fmoots

Well-Known Member
Joined
Jan 29, 2018
Messages
100
Likes
62
Age
33
#15
Thanks again Fmoots. I have now reloaded the Davinci software and am able to create optimised files. However, if I import a 4K clip of, say, 5 minutes length it takes around an hour to optimise it!!! Is that right? I suppose it's stripping the file back to raw and rebuilding it into something it feels it can work with, but I don't have the time (or inclination) to have to go through that process every time. Am I missing something?
What resolution have you set your optimised media clips to render to? You can check by going to your media tab and right clicking on the and tick the 'optimised media' box, it will then show which clips have optimised media along with the resolution/framerate etc:

Screen Shot 2018-04-07 at 14.40.02.png

If it is 'half res' and it is still stuttering you may want to consider changing it to 'Quarter Res'. If you're working with 4k footage you're still getting a 1080p image. To change this click on the cog on the bottom right and go to 'master settings', then under heading 'Optimised Media and Render Cache' you can set what you want the optimised media to be. By default it might be set to 'Choose Automatically, see below:

Screen Shot 2018-04-07 at 14.43.16.png

If creating optimised media is taking far too long, you can still work with proxies another way. Under the top 'Playback' menu, set your 'Proxy Mode' to either 'Half Resolution' or 'Quarter Resolution. Also ensure 'Performance Mode is on (this will allow smoother playback). Also if you are using optimised media ensure the 'Use Optimised Media if Available' in ticked. You can see all these below:

Screen Shot 2018-04-07 at 14.45.02.png

And what happens if you import a 4K clip but set the timeline to 1080p? Before rendering you just set it back to 4K.
Yes you can import a 4k clip onto a 1080p timeline, edit it, change your timeline to 4k, set your delivery settings for 4k when exporting and you will get a full 4k clip.
 

Fmoots

Well-Known Member
Joined
Jan 29, 2018
Messages
100
Likes
62
Age
33
#16
One more thing to note, go to your Davinchi preference and ensure your Geforce GT 1050 is definitely showing up and being recognised by Davinchi. You can also allocate more system memory and change the GPU processing mode. It should look like this:

Screen Shot 2018-04-07 at 14.53.46.png
 

BaNZ

Well-Known Member
Joined
Mar 28, 2018
Messages
94
Likes
24
#17
However, if I import a 4K clip of, say, 5 minutes length it takes around an hour to optimise it!!! Is that right? I suppose it's stripping the file back to raw and rebuilding it into something it feels it can work with, but I don't have the time (or inclination) to have to go through that process every time. Am I missing something?
The optimizing is very cpu and disk intensive. If you're laptop is not using SSD, then it will be slow for you. I'm using SSD and I can see read /write of up to 150mb/s.
 

Rivendell

Well-Known Member
Joined
Mar 6, 2018
Messages
45
Likes
10
Age
52
#18
OK, so some more info.

I have downloaded “Heaven Benchmark” and run the graphic card benchmark test a couple of times. I have compared this with various YouTube versions and my computer scores 1250, which is better than those I saw on YouTube (if you haven’t benchmarked your graphics card, this is a fun way to do it, with interesting ‘steam punk’ graphics).

I have also discovered that even the optimised 4K clip stutters when played backwards (the unoptimisable clip stutters forwards and backwards).

The render setting for optimised graphics is “automatic”. I tried to find out the degree of optimisation applied to my optimised clip, but couldn’t. However, when I used the Playback menu and set the proxy mode to “quarter resolution” and dropped an unoptimised clip into the timeline, the quality noticeably fell (even more obvious in full screen), but the playback was STILL JUMPY IN REVERSE. Performance mode is on. This is really weird as the quality is very low - a ZX Spectrum would handle it!

And what happens if you import a 4K clip but set the timeline to 1080p? Before rendering you just set it back to 4K.
I tried this and no difference.

Davinci is definitely recognising the graphics card (from the Davinci system menu).

I feel I’m becoming a bit of a pain with my Davinci woes! I have already downloaded the free trial of PowerDirect, but haven’t used it yet!

Sincere thanks to all who have helped.
 

Fmoots

Well-Known Member
Joined
Jan 29, 2018
Messages
100
Likes
62
Age
33
#19
OK, so some more info.

I have downloaded “Heaven Benchmark” and run the graphic card benchmark test a couple of times. I have compared this with various YouTube versions and my computer scores 1250, which is better than those I saw on YouTube (if you haven’t benchmarked your graphics card, this is a fun way to do it, with interesting ‘steam punk’ graphics).

I have also discovered that even the optimised 4K clip stutters when played backwards (the unoptimisable clip stutters forwards and backwards).

The render setting for optimised graphics is “automatic”. I tried to find out the degree of optimisation applied to my optimised clip, but couldn’t. However, when I used the Playback menu and set the proxy mode to “quarter resolution” and dropped an unoptimised clip into the timeline, the quality noticeably fell (even more obvious in full screen), but the playback was STILL JUMPY IN REVERSE. Performance mode is on. This is really weird as the quality is very low - a ZX Spectrum would handle it!



I tried this and no difference.

Davinci is definitely recognising the graphics card (from the Davinci system menu).

I feel I’m becoming a bit of a pain with my Davinci woes! I have already downloaded the free trial of PowerDirect, but haven’t used it yet!

Sincere thanks to all who have helped.
Hmm yeah sounds like there’s a bottleneck somewhere that is causing you issues.

Have you thought about adobe premiere? It does not require an upfront cost but rather a monthly subscription. It’s regarded by many to be the best editing software out there
 

Rivendell

Well-Known Member
Joined
Mar 6, 2018
Messages
45
Likes
10
Age
52
#20
Have you thought about adobe premiere? It does not require an upfront cost but rather a monthly subscription. It’s regarded by many to be the best editing software out there
I'll definitely have a look around. I'm never going to be a pro at this (of even a semi pro!). I'm simply looking to be able to do some fun edits for friends and family and the odd post. A simple user experience is important and Davinci, for whatever reason, isn't working out for me. But thanks Fmoots - you have been a star and even the questions you asked mean I know a lot more about video editing than before I started this thread!
 

New Threads

Forum statistics

Threads
53,260
Messages
621,507
Members
79,060
Latest member
Martincook