DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Galaxy Tab 3, Android 4.4.2, with Mavic Pro??

chrisonline

New Member
Joined
Oct 8, 2017
Messages
1
Reactions
0
Location
Front Royal, Virginia, United States
HI, I'm new to the forum (and to drones!), and I can already see that I will learn a lot from here.

Sorry if this is already covered, but I have searched it and found such a mass of discussion that I can't decipher my specific issue.

I have successfully set up my Mavic Pro with my Galaxy Tab S2 (running Android 7). No problems, it is excellent so far. Still a lot to learn, including customizing settings, and looking forward to the learning curve!

But I also have an older Galaxy Tab 3, running Android 4.4.2, sitting unused in the closet. I thought it would be ideal to set that up with my Mavic Pro and use it as a dedicated permanent setup. But on installing the latest DJI Go 4 app (v 4.1.9), it doesn't work. I connect the RC and aircraft, open the app on the tablet, and immediately get an error message that the app has closed (it never opens, so it fails as it starts). I tried reinstalling, same problem. I tried a different order of opening RC and app, same problem.

As far as I can see, Android 4.4.2 is supported, so I don't understand the problem. So my questions are:

1. Is anyone successfully using the Galaxy Tab 3 (NOT the S3) with DJI Go 4?
2. If so, did you have to tweak or customize anything?
2. Would it work if I rooted it?
3. Any other workaround, or other suggestions?

Any help and advice would be appreciated

Thnaks

Chris
Front Royal, Virginia, United States
 
The earliest I've tried is the Tab 4 - and while it ran DJI Go4, it wasn't powerful enough to make it worthwhile.

Aside from the Nvidia Shield tablet (and other premium devices) I wouldn't recommend anything from before 2015.
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
126,624
Messages
1,512,712
Members
156,171
Latest member
Enyalios