Get more from your Mavic
The largest Mavic community in the world
Join Us Now

Mavic Pro wont take off, only tilts forward and stops

jadedkingj

Member
Joined
May 2, 2018
Messages
10
Reactions
4
Age
38
Visit site
I really hope you guys can help me with this. I have had a Mavic Pro for about 4 monthes and yesturday took it out to fly and when I used the take off button or the manual engine start with the joysticks... the MPs blades sound like its going to take off but then it tilts forward and engines stop. I proceeded to do a IMU and Compass calibration and also a remote control Calibration, but still does the same thing. Im using DJI standard blades, updated firmware on remote/MP/Battery and have never had a issue with it since new. Any suggestions would be GREATLY appriciated!! Thank you in advance for any help you can give me!!
 
  • Like
Reactions: [email protected]

InvisibleName

Well-Known Member
Joined
Feb 5, 2018
Messages
1,860
Reactions
1,200
Age
63
Location
Peterborough, UK
Visit site
Ahh, maybe it’s only happening with the MA. I’d assumed that the prop to motor interface was the same. I’ve steered at least 2 new MA flyers in the last couple of months that they’d got their props mixed up.
 

ac0j

Well-Known Member
Joined
Sep 17, 2017
Messages
2,809
Reactions
2,266
Age
57
Visit site
The props do not fit on the wrong motors correctly, BUT I remember at least a few threads where people have managed to get them on. Probably broke something in the process. But it causes the mavic to try to flip when spooled up.
 

sar104

Dic mihi solum facta, domina.
Premium Pilot
Joined
May 27, 2017
Messages
12,671
Reactions
16,290
Location
Los Alamos, NM
Visit site
Ahh, maybe it’s only happening with the MA. I’d assumed that the prop to motor interface was the same. I’ve steered at least 2 new MA flyers in the last couple of months that they’d got their props mixed up.

Maybe so - I've never actually seen a Spark up close.
 
Joined
Aug 26, 2018
Messages
10
Reactions
1
Age
40
Visit site
I really hope you guys can help me with this. I have had a Mavic Pro for about 4 monthes and yesturday took it out to fly and when I used the take off button or the manual engine start with the joysticks... the MPs blades sound like its going to take off but then it tilts forward and engines stop. I proceeded to do a IMU and Compass calibration and also a remote control Calibration, but still does the same thing. Im using DJI standard blades, updated firmware on remote/MP/Battery and have never had a issue with it since new. Any suggestions would be GREATLY appriciated!! Thank you in advance for any help you can give me!!
Hi,

I’ve also had this problem yesterday with my Mavic Air... exactly the same as you. No issues last flight, no changes, had it over 3 months.... now it tilts forward right on take off and is unable to take off...

Have you found a way to fix it?
 

InvisibleName

Well-Known Member
Joined
Feb 5, 2018
Messages
1,860
Reactions
1,200
Age
63
Location
Peterborough, UK
Visit site
Hi,

I’ve also had this problem yesterday with my Mavic Air... exactly the same as you. No issues last flight, no changes, had it over 3 months.... now it tilts forward right on take off and is unable to take off...

Have you found a way to fix it?
You haven’t taken the props off recently, have you?
 
Joined
Aug 26, 2018
Messages
10
Reactions
1
Age
40
Visit site
Everything seems to be as it should ... I’ve never changed the props and it was flying perfect last flight ....
 

Attachments

  • 1353A90A-EEF6-4661-8616-61868F059507.jpeg
    1353A90A-EEF6-4661-8616-61868F059507.jpeg
    1.3 MB · Views: 17