Welcome Mavic Pilot!
Jump in and join our free DJI Mavic community today!
Sign up

Mavic Pro wont take off, only tilts forward and stops

jadedkingj

Member
Joined
May 2, 2018
Messages
10
Reaction score
4
Age
37
I really hope you guys can help me with this. I have had a Mavic Pro for about 4 monthes and yesturday took it out to fly and when I used the take off button or the manual engine start with the joysticks... the MPs blades sound like its going to take off but then it tilts forward and engines stop. I proceeded to do a IMU and Compass calibration and also a remote control Calibration, but still does the same thing. Im using DJI standard blades, updated firmware on remote/MP/Battery and have never had a issue with it since new. Any suggestions would be GREATLY appriciated!! Thank you in advance for any help you can give me!!
 
  • Like
Reactions: [email protected]

trebor

New Member
Joined
Aug 20, 2018
Messages
2
Reaction score
2
Age
46
It's not possible to install the props on the wrong motors - they don't fit.
Not that then. Not actually tried to miss-fit them on a Mavic but did once on a cheapy £20 drone and it wouldn’t fly.
 

InvisibleName

Well-Known Member
Joined
Feb 5, 2018
Messages
1,088
Reaction score
566
Age
62
Location
Peterborough, UK
Hey, try hard enough and you can force them on. Plenty on here done that!!
 
  • Like
Reactions: maverickau

InvisibleName

Well-Known Member
Joined
Feb 5, 2018
Messages
1,088
Reaction score
566
Age
62
Location
Peterborough, UK
Ahh, maybe it’s only happening with the MA. I’d assumed that the prop to motor interface was the same. I’ve steered at least 2 new MA flyers in the last couple of months that they’d got their props mixed up.
 

ac0j

Well-Known Member
Joined
Sep 17, 2017
Messages
2,809
Reaction score
2,256
Age
56
The props do not fit on the wrong motors correctly, BUT I remember at least a few threads where people have managed to get them on. Probably broke something in the process. But it causes the mavic to try to flip when spooled up.
 

sar104

Dic mihi solum facta, domina.
Premium Pilot
Joined
May 27, 2017
Messages
8,645
Reaction score
9,608
Location
Los Alamos, NM
Ahh, maybe it’s only happening with the MA. I’d assumed that the prop to motor interface was the same. I’ve steered at least 2 new MA flyers in the last couple of months that they’d got their props mixed up.
Maybe so - I've never actually seen a Spark up close.
 

UAVNV

Well-Known Member
Joined
Jul 19, 2017
Messages
235
Reaction score
146
Age
42
sunlight? obstacle avoidance system?
 
Joined
Aug 26, 2018
Messages
10
Reaction score
1
Age
39
I really hope you guys can help me with this. I have had a Mavic Pro for about 4 monthes and yesturday took it out to fly and when I used the take off button or the manual engine start with the joysticks... the MPs blades sound like its going to take off but then it tilts forward and engines stop. I proceeded to do a IMU and Compass calibration and also a remote control Calibration, but still does the same thing. Im using DJI standard blades, updated firmware on remote/MP/Battery and have never had a issue with it since new. Any suggestions would be GREATLY appriciated!! Thank you in advance for any help you can give me!!
Hi,

I’ve also had this problem yesterday with my Mavic Air... exactly the same as you. No issues last flight, no changes, had it over 3 months.... now it tilts forward right on take off and is unable to take off...

Have you found a way to fix it?
 

InvisibleName

Well-Known Member
Joined
Feb 5, 2018
Messages
1,088
Reaction score
566
Age
62
Location
Peterborough, UK
Hi,

I’ve also had this problem yesterday with my Mavic Air... exactly the same as you. No issues last flight, no changes, had it over 3 months.... now it tilts forward right on take off and is unable to take off...

Have you found a way to fix it?
You haven’t taken the props off recently, have you?
 

InvisibleName

Well-Known Member
Joined
Feb 5, 2018
Messages
1,088
Reaction score
566
Age
62
Location
Peterborough, UK
No, I’ve never had reason to ... no issues last flight or no changes made ....

What should I be checking on the props just in case?
That the 2 with the white marks are on the corresponding white marked motors