Welcome Mavic Pilot!
Jump in and join our free DJI Mavic community today!
Sign up

Vision sensor and Disconnect

Joined
Jan 27, 2017
Messages
21
Reaction score
14
Age
41
Been flying my MP with the same ipad mini for 2 years with no problem. Flew in Hawaii last week with no issues, then 2 nights ago back home i got a Vision Sensor error. After some research i did a calibration through the DJI assistant 2. Boom, that resolved the error. While i was at it i did a firmware update. So last night i got up in the sky, flew around for a few minutes and suddenly i noticed that my ipad was blank and was telling me that the aircraft was disconnected. It could have been 2 seconds or 2 minutes, i'm not sure since it was flying just fine and i had a visual on it and wasn't looking at the screen. I landed, killed the battery and controller, waited a few seconds and fired them back up. Got the green light, good to go, and off i went. This time eyes glued to the ipad. Sure enough after a few minutes of flying the aircraft disconnected. Nothing in my circumstances have changed. I fly from my front yard all the time and i live outside of town with no obstructions. I have no clue what's causing this or how to correct it. Any input is appreciated. Thanks!
 

Mav.phant.inspire

Well-Known Member
Joined
Sep 20, 2017
Messages
98
Reaction score
103
Age
17
Loc
Mcbride BC
One guess is that there is a loose connection, try with a different device if possible. Does your iPad charge like normal still? Also make sure everything is updated. Other than that seems a touch strange
 

Sniperfritz

Well-Known Member
Joined
Jan 30, 2019
Messages
179
Reaction score
130
Age
37
Loc
Port Elizabeth ,SA
I had similar problem last week. I was using my iPad 9.7 2018. The iPad would randomly disconnect, while the controller stayed connected. Turned out I was touching the cable on the iPad side. Replaced it with cable that has right angle on the connector. Worked for me.
 
  • Like
Reactions: WAXMAN
Joined
Jan 27, 2017
Messages
21
Reaction score
14
Age
41
Well i flew this evening and had zero problems with it, i changed nothing so i'm really unsure what's going on. I feel as though my video feed is more choppy than usual, but i could be hyper sensitive to it since i've been having problems.
 

New Threads

Forum statistics

Threads
60,060
Messages
701,170
Members
87,075
Latest member
Nuke71