DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Skip to FCC mode

Pante90

New Member
Joined
Oct 1, 2021
Messages
3
Reactions
0
Age
31
Location
Miami
Hello everybody,
i want to ask if someone know how to skip in FCC mode my Mavic Air 1 because i tried with a normal procedure with FakeGPS and Android device, but nothing change on wifi channel, still remain on 13 channel not 11. What i can do?! there are another way?
thank a lot for help me!
 

umanbean

Well-Known Member
Joined
Jul 9, 2018
Messages
575
Reactions
547
Age
67
Location
Ga USA
If you're in the US (Miami), and bought your drone from a US vendor, your MA1 should already be in FCC mode.
 

Pante90

New Member
Joined
Oct 1, 2021
Messages
3
Reactions
0
Age
31
Location
Miami
I know, because i'm from Italy, and now i live in Miami. But the fcc isn't change automatically. i don't know why.
 

Facherty

Well-Known Member
Joined
Mar 31, 2019
Messages
154
Reactions
98
Location
Edinburgh, Scotland
I fly using an iPhone, so it's slightly more complicated for me, since there is no way of fooling iOS about your location. I have to use an Android device to make the change, and then remember NOT to change it back when using my iPhone.
Therefore I have written the instructions out for myself.
(If you don't use iPhone, you only need the first two sections below).

Reset Mavic Air to FCC Mode Using Android and Android App


Preparation​

On the Android, download and launch the app Fake GPS

Remove gimbal protector from Mavic Air

Power on the Lenovo

Android​

Connect Mavic Air controller to Android

Launch the app Fake GPS

Locate Texas and choose play button

Start the controller

Start the Mavic Air – no need to start motors

Wait until they are linked (red light on controller goes green)

DJI Go 4 will automatically start on the Android; if not, launch it

Wait until Enter Device > has gone and press Go Fly on DJI Go 4

Ignore any requests for a database update

DJI Go 4 will report that the Wi-fi has to be reset:

Switch Wi-Fi Settings
Your aircraft is flying in a different country/region. Aircraft will reset its Wi-fi...

Click OK.

Unplug the Mavic Air Controller from the Lenovo, and turn it off, then turn the Mavic Air off

iPhone​

Connect the iPhone into its usual position in the Controller, and turn the Controller on, and then the Mavic Air

When the Controller and Mavic Air have finished their startup and binding (red light on controller goes green), launch DJI Go 4 on the iPhone

Cancel and ignore any update warnings

DJI Go 4 will report that the Wi-fi has to be reset:

Switch Wi-Fi Settings
Your aircraft is flying in a different country/region. Aircraft will reset its Wi-fi...

This time choose Cancel.

Check the wi-if symbol has a small 2.4G beside it.



The procedure is also in the .pdf attached.
 

Attachments

  • Reset Mavic Air to FCC Mode Using Lenovo and Android App.pdf
    48.1 KB · Views: 31

Pante90

New Member
Joined
Oct 1, 2021
Messages
3
Reactions
0
Age
31
Location
Miami
Hello,
i just try this guide but, doesn't worlk. nothing change on wifi onboard. i want to ask if someone know if i downgrade the firmware, maybe this guide works properly.
 

Facherty

Well-Known Member
Joined
Mar 31, 2019
Messages
154
Reactions
98
Location
Edinburgh, Scotland
It may help others to assist you if you can say whereabouts in the procedure (above) the process fails, since it works for me and others.

I can't advise you on downgrading your firmware - I know too little about it. However, I can add that in the the last two years I have never upgraded the firmware, the batteries, the iPhone or the DJI Go 4 app. I ignore upgrade messages, including the FlySafe database, because the drone is flying efficiently and effectively.
 
Joined
Apr 17, 2022
Messages
8
Reactions
4
Age
40
Location
South africa 🇿🇦
It may help others to assist you if you can say whereabouts in the procedure (above) the process fails, since it works for me and others.

I can't advise you on downgrading your firmware - I know too little about it. However, I can add that in the the last two years I have never upgraded the firmware, the batteries, the iPhone or the DJI Go 4 app. I ignore upgrade messages, including the FlySafe database, because the drone is flying efficiently and effectively.
Good day. If I may ask you to please provide the version of dji go 4 you using and software of drone if possible. Im also having the same issue as well. I currently have everything to the latest. Can't get fcc with fake gps trick. I'm in south africa.
 

Facherty

Well-Known Member
Joined
Mar 31, 2019
Messages
154
Reactions
98
Location
Edinburgh, Scotland
Can't advise you on that.

I also have a Mini SE which I want to put in FCC mode since 5.8GHz is so bad in the UK. However, DroneHacks were quick to inform that their software could not help with that problem.
 

Mcgon

Active Member
Joined
Jan 27, 2018
Messages
44
Reactions
23
Location
Dublin, Ireland
Can't advise you on that.

I also have a Mini SE which I want to put in FCC mode since 5.8GHz is so bad in the UK. However, DroneHacks were quick to inform that their software could not help with that problem.

I came back here as I have the same issue. I put my Mavic Air into FCC mode years ago and just ignored requests to adjust WLAN settings each time I start. However, I chose ok to reset WLAN settings by mistake this week. The steps above (which did work for me in the past -) no longer work. I guess the app version blocks this somehow. So I was open minded and went for a flight in CE mode.... Terrible. lost signal at 150m in 5,8ghz (line of sight). Lot of grey screen too. So I tried 2.4ghz. marginally better - 300m before signal loss, grey screen, and aircraft disconnect. The last 3 years I've enjoyed 800m range in the same area with no loss of signal or image.
Is there any way to get back to FCC mode (without flying to the US :) )
 

Facherty

Well-Known Member
Joined
Mar 31, 2019
Messages
154
Reactions
98
Location
Edinburgh, Scotland
I came back here as I have the same issue. I put my Mavic Air into FCC mode years ago and just ignored requests to adjust WLAN settings each time I start. However, I chose ok to reset WLAN settings by mistake this week. The steps above (which did work for me in the past -) no longer work. I guess the app version blocks this somehow. So I was open minded and went for a flight in CE mode.... Terrible. lost signal at 150m in 5,8ghz (line of sight). Lot of grey screen too. So I tried 2.4ghz. marginally better - 300m before signal loss, grey screen, and aircraft disconnect. The last 3 years I've enjoyed 800m range in the same area with no loss of signal or image.
Is there any way to get back to FCC mode (without flying to the US :) )
The last time that I did the same thing (accidentally reset the location, and hence WLAN settings) I managed to use the fix above successfully.

Is there any way you can downgrade the either the Go 4 app or the phone operating system? I have left my iPhone Xs on iOS 13.6 just to avoid any form of upgrading affecting the distance or strength of the Mavic Air radio connection.

[The only other thing I should have put in the instructions 8 posts above is to make sure you do all of this inside the house - you don't want the Mavic Air itself catching any satellites.]
 
  • Like
Reactions: Mcgon

Mcgon

Active Member
Joined
Jan 27, 2018
Messages
44
Reactions
23
Location
Dublin, Ireland
The last time that I did the same thing (accidentally reset the location, and hence WLAN settings) I managed to use the fix above successfully.

Is there any way you can downgrade the either the Go 4 app or the phone operating system? I have left my iPhone Xs on iOS 13.6 just to avoid any form of upgrading affecting the distance or strength of the Mavic Air radio connection.

[The only other thing I should have put in the instructions 8 posts above is to make sure you do all of this inside the house - you don't want the Mavic Air itself catching any satellites.]

Thanks for your reply.

Good news everyone - I got it sorted. :D

The issue is that the DJI GO 4 app version 4.3.46 (android 12) doesn't allow this hack anymore. By the way, version 4.3.46 is only available from the DJI website. The previous version 4.3.37 is downloadable from google play store - but alas it does not launch on Android 12 (Pixel 5). It installs, but won't launch.

Luckily, I still had an older phone on Android 11 (pixel 2) in a box somewhere. This phone still had DJI GO 4 version 4.3.37 installed on it. I installed the fake GPS app on the old phone (no sim in the phone, but I could connect to google play from my wifi). I followed the standard hack procedure as outlined above. It worked. I chose OK to change my WLAN settings to US region.

Now the real test. When I plug the remote back into my Pixel 5 (Android 12) with version 4.3.46 on it. Would it still remain in FCC mode.... YES! The pop up appeared 'your aircraft is flying in a different region...'. I chose 'cancel' when prompted to change my WLAN settings. I confirmed the wifi channel screen still shows only 11 2.4ghz channels (FCC) not 13 (CE).

Now the real REAL test. I took a flight on the very same route I did earlier today. This time... No grey screen. No aircraft disconnect. No weak signal. No issues at all out to 500m (as far as I went). Not surprising given the FCC power output is more than double in 5.8ghz mode and almost double in 2.4ghz mode. (see stats highlighted in Mavic air spec sheet).

I hope this is helpful for people. You will basically need Android 11 and DJI GO 4 version 4.3.37 to apply the hack. (4.3.37 won't launch on Android 12!)
The hack cannot be applied using Android 12 and DJI GO 4 version 4.3.46 (only version that launches on Android 12).
However, once the hack is applied you can use 4.3.46 on Android 12 - just be careful to always hit 'cancel' when asked if you want to update your WLAN settings!
 

Attachments

  • drone.jpg
    drone.jpg
    575.9 KB · Views: 12
  • drone2.jpg
    drone2.jpg
    57.2 KB · Views: 11
  • Like
Reactions: Facherty

MJZ

New Member
Joined
Sep 11, 2022
Messages
3
Reactions
0
Location
Lithuania
Thanks for your reply.

Good news everyone - I got it sorted. :D

The issue is that the DJI GO 4 app version 4.3.46 (android 12) doesn't allow this hack anymore. By the way, version 4.3.46 is only available from the DJI website. The previous version 4.3.37 is downloadable from google play store - but alas it does not launch on Android 12 (Pixel 5). It installs, but won't launch.

Luckily, I still had an older phone on Android 11 (pixel 2) in a box somewhere. This phone still had DJI GO 4 version 4.3.37 installed on it. I installed the fake GPS app on the old phone (no sim in the phone, but I could connect to google play from my wifi). I followed the standard hack procedure as outlined above. It worked. I chose OK to change my WLAN settings to US region.

Now the real test. When I plug the remote back into my Pixel 5 (Android 12) with version 4.3.46 on it. Would it still remain in FCC mode.... YES! The pop up appeared 'your aircraft is flying in a different region...'. I chose 'cancel' when prompted to change my WLAN settings. I confirmed the wifi channel screen still shows only 11 2.4ghz channels (FCC) not 13 (CE).

Now the real REAL test. I took a flight on the very same route I did earlier today. This time... No grey screen. No aircraft disconnect. No weak signal. No issues at all out to 500m (as far as I went). Not surprising given the FCC power output is more than double in 5.8ghz mode and almost double in 2.4ghz mode. (see stats highlighted in Mavic air spec sheet).

I hope this is helpful for people. You will basically need Android 11 and DJI GO 4 version 4.3.37 to apply the hack. (4.3.37 won't launch on Android 12!)
The hack cannot be applied using Android 12 and DJI GO 4 version 4.3.46 (only version that launches on Android 12).
However, once the hack is applied you can use 4.3.46 on Android 12 - just be careful to always hit 'cancel' when asked if you want to update your WLAN settings!
What firmware is your aicraft and remote ?
 

DJI Drone Deals

New Threads

Forum statistics

Threads
121,341
Messages
1,431,595
Members
149,032
Latest member
Opi