DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Can’t pair remote to drone

bburnett15

Well-Known Member
Joined
Sep 11, 2020
Messages
193
Reactions
56
Age
65
Location
massachusetts
I have been flying my Mavic 2 pro pretty much exclusively with the smart controller. Now I have the Tripltek 8 that I want to use with the original controller for the M2P but I can’t get the remote to pair with the drone. This happened once before and somehow I was able to get it to work, I just don’t remember how. The controller displays “connecting” and that’s all. The Tripltek screen where I am running litchi is black and just has a message “signal lost.” There are no DJI apps running in the background, batteries are charged. I am using the Tripltek charging cable to connect tablet to controller ( the first time I used that cable for the connection was the one time I have been able to make it work)
I purchased the Tripltek with the intent to use it with litchi as the telemetry on the screen is too small to easily read, which makes it easy to loose sight of the drone while straining to read the screen.
THANKS!!
 
Are you triggering linking on both the drone and the controller?
Assuming so, try removing the mSD card from the drone. I had this happen with a M2Z and it was either a corrupted file or an inappropriately named file on the card that was causing the problem, I forget which.
 
Found the solution- because i intend to keep the tripltek dedicated to Litchi use, I didnt want to open DJI apps on the Tripltek, so i connected my phone to the remote control and opened Go4. in the settings i selected link controller to drone, it started beeping, i hit “the button”, and it was synced and everything worked with Go4.
I shut it down and reconnected Tripltek and turned it all on, used litchi and it worked like a charm!
 
You do not need a screen device to trigger linking, have a look at watch form 46sec onwards.
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
129,901
Messages
1,547,323
Members
158,970
Latest member
MrJenkins