DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Control link is lost shortly after take off

stop

Member
Joined
Jun 12, 2022
Messages
10
Reactions
2
Age
56
Location
N. America
I experienced a strange issue several times. Soon after the take off the control signal disappears, the video recording on the drone stops. The video link to the controller stays up. It goes on for several seconds, until the auto return is started. The control link is reestablished almost immediately and the recording is restarted. The drone flies normally thereafter. Examining the files, I noticed that the short videos before the signal is lost were exactly the same size, so in both cases, the signal was lost 12 seconds after I started the recording (not after taking off). I just don't know what to make out of it. Once it happened when I was under trees, and the drone almost went up into them while trying auto return.
 
try, in a safe area with no trees, perhaps four flights over, as best you can, exactly the same flight path including height. Fly one flight without ANY video then the next with video and repeat.
That said flying under trees with failsafe set to RTH is asking for trouble, better to set it to hover and walk the controller back int to reconnection.

It might be an idea to post the flight logs for the flight of post 1 and any experiments.
 
  • Like
Reactions: stop
I checked the flight log, and couldn't see anything unusual: Good idea on setting to hover instead of auto return, thank you.
 
At a guess you found that log in somewhere with a path like

Phone\Android\data\com.aryuthere.visionplus\files\flightlogs

instead you might like to have a look in

Phone\DJI\com.aryuthere.visionplus\FlightRecord

you might find complete .txt and DAT flight logs there. You could try searches for "DJIFlightRecord" or "MSDK".

If successful could you upload, at a guess, DJIFlightRecord_2023-07-29_[20-24-09].txt to
and post the URL here?
 
This is the log. The problem started around 0:15. Does the drone store the log while the comms are lost and send them later or is the outage data missing?
I did several more test flights today. I could replicate the problem every time. The drone had to be powercycled for teh problem to occur again. It would not happen while the video recording was stopped. I made one mistake in my description- while the video signal indicator would show 5 bars, the video is actually frozen.
I tried switching the recording quality between 2,7k and 4k, it didn't help. I'm using the same SD card I had for over a year.

Note to self: Litchi logs are in Android/data/com.aryuthere.visionplus/files/flightlogs
 
The drone stores a DAT in its internal memory, from drone switch on to drone switch off. You can get to it and download it via the appropriate Assistant 2 but sadly you will not be able to read the DAT, it's encrypted, mutter mutter mutter.
If you want to try downloading the log make sure the drone's battery is fairly full and arrange a fan to blow air over the drone whilst the drone is switched on, it's likely to take a while.

Did you upload the Litchi csv to Phantomhelp rather than the .txt ?
 
Yes, I uploaded .csv, and it appears to be decoded perfectly
There is not much in the encrypted logs...
I tried to do some more troubleshooting, while lamenting that I didn't open a ticket with DJI as soon as I noticed the problem- my warranty ran out the day after my first post here. The problem appeared reliably. I switched SD cards, tried different video quality settings- nothing changed. Also found that I don't even have to take off- starting recording while idling on the ground also caused the problem to appear. After one of the tests, the problem went away and hasn't come back since.
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
129,912
Messages
1,547,437
Members
158,977
Latest member
mckhr