DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

DJI Assistant 2 not working

mini2flyer

Member
Premium Pilot
Joined
Jun 16, 2023
Messages
22
Reactions
4
Age
20
Location
SD
I have tried everything I know of to get DJI assistant 2 to work on my Mac. It’s like the ports on the computer get no input. Can anyone help?
 
And you are using the correct version of DJI Assistant 2? There are several different versions for different drone models.

Go here ---> DJI Assistant 2 (Consumer Drones Series) - Download Center - DJI and there in the left column chose the one that is compatible with the drone you have (they list compatible equipment for each version in the bottom of each page).

1708594251823.png

Also, some of the versions for the older equipment aren't fully compatible with the latest macOS versions...

1708594459759.png
 
  • Like
Reactions: Cafguy
I tried to get the consumer drone series but I have the latest version of macOS so is there no solution or workaround?
 
I tried to get the consumer drone series but I have the latest version of macOS so is there no solution or workaround?
You haven't mentioned which drone you have...

If it's any of the models the "Consumer drones series" support & you still can't get it to work on your mac--> then as mentioned, borrow a windows machine.

And it's equal if you have an older drone model that require a Assistant 2 version that doesn't support the latest macOS
--> borrow a windows machine.
 
FPV drone with DJI O3. I guess I’ll see if I can find a windows to use
 
They are right above and my new Mac Book Air gave a grunt and said no go. Luckily I have not disposed of my laptop and loaded it perfectly. The laptop is 12 years old!
 
So I borrowed a older windows and I still can’t get the software to recognize when I plug the drone in
 
And you power the drone on, right? Otherwise it will not work...
 
And you're sure that the cable you use is a data cable & not only one for charging..?
 
I'm having the same problem. I got a Mini 4 Pro for Christmas. I was able to connect to my Mac in January with DJI Assistant 2 and I just tried again yesterday and got nothing. Deleted and reloaded the software (I'm using the right version), tried different cables and connection types, got nothing. It's like my computer doesn't even see it as the photos don't show up on the desktop like they should. It does connect to my iPad with DJI Fly but I'd really like to be able to use Assistant 2. Anyone have any ideas on how to connect again?


Nevermind, after trying everything I could think of to get it working without success I just tried it one last time and now it's working. Have no idea why I'm good to go again.
 
Last edited:
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Members online

Forum statistics

Threads
130,955
Messages
1,558,301
Members
159,956
Latest member
shakes60