DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Intelligent Flight Modes

celdcl

Member
Joined
Jul 31, 2019
Messages
13
Reactions
12
Age
65
I'm using an Ipad 5 with original Mavic Air, and the icon (according to the manual) to initiate Intelligent Flight Modes doesn't do anything. It seems like its supposed to appear on the left side of the screen, but does not. It shows up along the top of the screen, but that seems to just allow changes to an irrelevant setting; nothing about flight modes shows up. What the heck am I doing wrong? I haven't cared until now but am getting adventurous enough to want to try it out.
 
It might be
  • your in sport mode
  • you have poor gps signal indoors
 
  • Like
Reactions: dawgpilot
It might be
  • your in sport mode
  • you have poor gps signal indoors
Not in sport mode (I'm not that confident yet), and its outdoors. A real mystery. Its a shame not to be able to use that incredible technology.
 
If you're looking for it before firing up the drone you won't see it. You have to be in flight.
 
Try uninstalling Go4 and do a fresh install. If this not do anything, try using another mobile to ensure it is not a device problem. It seams anyway like an app miss behavior.
 
I kinda remember having the same problem. are you more than 6 ft above the ground..I think maybe I wasn't high enough.
It should look like this. The drone will start and fly without being connected to the app. of course you won't have the camera. Could it possibly be that you aren't connected or perhaps using a phone that isn't up to the task..My Mavic Air wouldn't work with my 5s even though the Spark flew perfectly with it using the same app. The DJI GO 4. I could hook up to the Mavic Air but nothing worked as it should.
 
I found the solution; using the controller (not the app on the ipad, but while connected to the ipad) I switched from P mode to sport mode, then back. The active track icon miraculously appeared. Very weird, but problem solved.
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
132,256
Messages
1,571,441
Members
160,995
Latest member
reginald123456