DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Live feed disconnected

_seven

Member
Joined
Nov 20, 2022
Messages
23
Reactions
11
Location
Philippines
Hello,

i;ve been using 2 sets of Mavic 3 (dual) for quite some time now and finally decided to pull the trigger on a Mavic 3 pro mainly because of the tele camera 10bit dlog M update

im currently using the Mavic3p paired with my RC Pro, and been happy with it until yesterday, was doing some standard shots in the city (with permits) and my feed froze and it triggered RTH, the maps is still working and drone has telemetry, just a frozen feed. i landed and restarted, all is well until it happened a second time on a different part of the city im filming in.

any ideas why is this happening? never happened on my 2 other m3s before. this is weird since even during RTH when the drone is almost on top of me, feed never resumes but i have full telemetry and I still have full control on the drone, just no feed
 
Last edited:
You have said you have no video.
Do you mean the app has telemetry and no video. Or a black screen.

Iv had instances where a reboot of the fly app in flight restores both conditions.

If like you said just the video feed only is missing... that's out of the ordinary.

As a programmer my first resolution would be to look from the drone itself not sending video.

I'm curious... never heard that before except for out of range conditions... or exceptional interference.

Also try manually changing the transmission to a narrow 10khz band and select a channel with less interference.

That's my thoughts for now... based on what you described
 
Last edited:
  • Like
Reactions: _seven
You have said you have no video.
Do you mean the app has telemetry and no video. Or a black screen.

Iv had instances where a reboot of the fly app in flight restores both conditions.

If like you said just the video feed only is missing... that's out of the ordinary.

As a programmer my first resolution would be to look from the drone itself not sending video.

I'm curious... never heard that before except for out of range conditions... or exceptional interference.

Also try manually changing the transmission to a narrow 10khz band and select a channel with less interference.

That's my thoughts for now... based on what you described
I have a Freeze frame from video, like the last thing it sees before getting 'disconnected' colored "photo" of the live feed before disconnecting but the maps, moves so as the telemetry, really weird, i even tried to cancel rth, exited the app and reopen it and now have black screen while telemetry and map still works,

i'll try to manually set transmission as you advised

(just a note: i've did some obstructed range test before, managed to get 4km before the feed cuts but the feed reconnects once the drone is close enough, mostly around 3km. )
 
I would try a factory reset of the controller
 
  • Like
Reactions: _seven
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
129,877
Messages
1,547,079
Members
158,952
Latest member
ikarma