Welcome Mavic Pilot!
Jump in and join our free DJI Mavic community today!
Sign up

Loses GPS, System Error Check App in Litchi

Joined
Dec 2, 2017
Messages
16
Likes
3
Age
48
#1
I have the alpine white version of the MP and almost every flight at some point the drone drifts out of control and gives a system warning check app whole flying using Litchi. The controller still works with the drone in atti mode but it flies erratically. I stay calm and it eventually voes back to GPS and stabilizes. I've calibrated, formatted SD card on drone, and tried different cards with no luck. Litchi gives me no log and airdata just indicates a switch to atti and then back to gps. I have full satellites when taking off and usually this happens a few minutes into the flight when trying to go somewhere. My previous MP never had this problem. Formware is up to date.
 

lisadoc

Well-Known Member
Joined
May 29, 2017
Messages
1,020
Likes
663
#2
I have the alpine white version of the MP and almost every flight at some point the drone drifts out of control and gives a system warning check app whole flying using Litchi. The controller still works with the drone in atti mode but it flies erratically.
Does the same happen if you use DJI Go 4?
 
Joined
Dec 2, 2017
Messages
16
Likes
3
Age
48
#3
This is still happening every flight. Last flight I switched to dji4 app while it was stuck in the system warning error and it said "Compass calibration error." After another minute or so it went back to gps and flew fine. I've calibrated several times and it continues to happen every flight.
 

radxor

New Member
Joined
Aug 6, 2018
Messages
2
Likes
0
Age
46
#4
Are you flying near something that might cause magnetic interference, like a bridge? I just experienced the same error while flying near a bridge. One time I was flying manually with Litchi and the "Sys Error Check App" warning came on, and the MP starting drifting uncontrollably and crashed. A second time, I plotted a course near the bridge and at one point the "Sys Error" flashed and MP went to Atti mode. I suspect the problem was magnetic interference due to the bridge. Weird because I was able to do the exact same path a few minutes prior with no problems.
 
Joined
Dec 2, 2017
Messages
16
Likes
3
Age
48
#5
It happens in flight a few hundred feet up but nowhere near magnetic interference because most flights are in the country. However, I often take off near my RV so I will try some different take off locations to rule that out.
 

radxor

New Member
Joined
Aug 6, 2018
Messages
2
Likes
0
Age
46
#6
I would try going to a field with no metal or anything else that might cause magnetic interference and recalibrate the compass. I suspect your drone’s compass may have been calibrated near some magnetic interference (e.g.your RV). Once your drone has taken off and leaves that magnetic environment, the compass is off, causing the System Error. That seems to have been my problem. Once I recalibrated the compass in a nice open field, I was able to come back to my original location and run the waypoint mission without problems.
 
Joined
Dec 2, 2017
Messages
16
Likes
3
Age
48
#7
I've done this a few flights now, where I am out in the woods with nothing magnetic and I calibrate compass and then every single flight has a system warning and loses GPS for 10-60 seconds a few minutes into the flight. Also, the drone has never flown straight either, in any direction, and I have calibrated the controls several times too. As I stated before, I had an older MP and it didn't have these problems during flights, all with similar circumstances.
 

New Threads

Forum statistics

Threads
47,265
Messages
552,579
Members
69,914
Latest member
okabass