DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

M2P Aircraft not connected?

Chafey

Member
Joined
May 1, 2018
Messages
7
Reactions
0
Age
55
After much anticipation I've finally received my new Mavic 2 Pro. Went through the process on DJI Go4 app to activate the aircraft. At the end of the process it says activation sucessful and shows the images from the camera.....However, at the top in red it states aircraft disconnected? The camera will move using the remote wheel on the remote, so I'm guessing the remote is connected, but it will not start the motors???
When I come out of the app and go back in, it asks to activate again and I go through the same process?? Six times later still no joy?? Also the image on the app shows my previous Mavic Pro model, not the new one?? Am I missing something?? Any help would be most appreciated.....Simon
 
Only thing I can think of, since you are seeing the older MPP, is your DJIgo4 app current?. There have been at least 2 updates since the MP2 was released. But the fact that your activation keeps coming back is troubling. That does imply a bigger issue.

Remote will say Connected on the display if you are connected and should have a green light. But if you are moving the camera it's probably connected via RC, so error seems to be on the app side.

If you have most current version of DJIgo4, I would consider pulling it off, and re-installing it, and or see if you have a different cable. I would also use the standard USB port on the bottom of the controller for a test as the mini port albeit conveniently for phones has been problematic at times.

Paul C
 
  • Like
Reactions: Chafey
Only thing I can think of, since you are seeing the older MPP, is your DJIgo4 app current?. There have been at least 2 updates since the MP2 was released. But the fact that your activation keeps coming back is troubling. That does imply a bigger issue.

Remote will say Connected on the display if you are connected and should have a green light. But if you are moving the camera it's probably connected via RC, so error seems to be on the app side.

If you have most current version of DJIgo4, I would consider pulling it off, and re-installing it, and or see if you have a different cable. I would also use the standard USB port on the bottom of the controller for a test as the mini port albeit conveniently for phones has been problematic at times.

Paul C
Thanks Paul, I too was thinking about deleting and 're installing the app.....Will give it a go later and see what happens...
 
After much anticipation I've finally received my new Mavic 2 Pro. Went through the process on DJI Go4 app to activate the aircraft. At the end of the process it says activation sucessful and shows the images from the camera.....However, at the top in red it states aircraft disconnected? The camera will move using the remote wheel on the remote, so I'm guessing the remote is connected, but it will not start the motors???
When I come out of the app and go back in, it asks to activate again and I go through the same process?? Six times later still no joy?? Also the image on the app shows my previous Mavic Pro model, not the new one?? Am I missing something?? Any help would be most appreciated.....Simon
IOS or Android?
 
IOS ......but as stated deleting the app and 're installing has sorted it....it's all up and running, just waiting for a break in our UK weather to take it out for its maiden flight.
 
IOS ......but as stated deleting the app and 're installing has sorted it....it's all up and running, just waiting for a break in our UK weather to take it out for its maiden flight.

Good for you. I'm in the same boat at present, rubbish weather for 10 days. What makes it worse is I live on the Sunshine Coast of QLD, Australia. :D
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
132,765
Messages
1,576,554
Members
161,488
Latest member
spawnb