Get more from your Mavic
The largest Mavic community in the world
Join Us Now

MA not linking

BaNZ

Well-Known Member
Joined
Mar 28, 2018
Messages
98
Reactions
25
EDIT: I FIXED IT via this link.

It was exactly what the other users were having. Front red light was not on, I cannot see the Mavic Air SSID. A few things that might have triggered this. Switching between WIFI + RC. Or going to a different country.

My method was pretty simple. Hold down the function button and wait for 3 beeps. Switch it off and pull out the battery. I believe pulling out the battery did the trick for me as I reset it multiple times and I was not able to connect. Then I switched off the phone wifi and use wired connection.

Pretty sure the unit malfunction. It's on the latest firmware 1.00.04.

The day before yesterday, I connected to the MA using WIFI + phone to download some photos. Then I switch it back to RC + phone. I flew it yesterday with RC + android. It all went well then I caught a flight back home. I leave it in my carry on luggage because I didn't want to check in the drone.

Now I'm trying to connect to wifi. I hold the function button till I get double beep. I scan the barcode and it wouldn't connect, so I try manually connecting. I don't even see the wifi ssid popping up. So I think it must be something wrong with the wifi. I then try connecting the RC + android. I also can't link them. It just times out, I don't even get the red light in the front arm so I think something must be wrong.

Time for factory reset with dji assist. After factory reset, the red led in the front is coming up. But no luck, still can't pair it either method. Wifi or wired, no luck. I also tried pairing it with the RC + drone only.

Also tried linking with Ipad + thunderbolt connector, no luck.

Fire up dji assist, I do a refresh of the firmware. At least it still connects and see the drone. But I just can't get it to connect via RC or wifi. Help!
 
Last edited:
Lycus Tech Mavic Air 2 Case

New Threads

Forum statistics

Threads
103,963
Messages
1,204,244
Members
132,644
Latest member
Jepsen