DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Mavic 3 battery weird state

gylka

New Member
Joined
May 15, 2024
Messages
4
Reactions
1
Age
40
Location
Ukraine
Hello everyone.

I received 2 batteries that came with Mavic 3 (I think it was Mavic 3T actually). The owner told that he placed them on an original charger and left for a while and after he returned they were in this weird state (photos below) where 2 middle LEDs turned on no matter what you do. I tried to connect to it via DJI Battery Killer and no luck, BMS doesn't "reply". It doesn't charge (only slowly discharge due to LEDs being constantly on). When you put it in Mavic 3 - drone actually turns on but reports battery error and won't flight. In menus battery info is empty.
Haven't find anywhere what does this state mean. Also tried to de-solder batteries from BMS one-by-one until lights will go off and after they did - solder them back and battery still has 2 middle LEDs on.
Does anyone knows what does this state mean or what would you recommend on doing to fix these batteries (I know of service centers, but I'd prefer to fix it now if there is an easy fix). Thank you
 

Attachments

  • image_2024-05-15_143643566.png
    image_2024-05-15_143643566.png
    402.7 KB · Views: 14
  • Haha
Reactions: tiktoksss
I have had the exact problem with 3 mavic 2 batteries. Anyone know what caused this? One of the batteries was brand new from DJI. I sent it back, waiting for info from the DJI service department.
 
@smoluse , please write here after service respond to you. I'd really would like to know what's the issue may be. Thank you
 
@smoluse , please write here after service respond to you. I'd really would like to know what's the issue may be. Thank you
Since this was a new battery, i sent it to DJi. Today they said they were replacing it but they provided no information on the cause. I don't think this was a manufacturing issue since i had two older batteries that suddenly had the same issue. Only two things come to mind. I could have used these three batteries over the past few months to update my mavic firmware..i have two aircraft. No idea if these were the batteries i used. I understand that firmwate updates the battery too. Only other thing could be that i tried to recharge these before they were cooled down completely.. i know not to do that, but perhaps i messed up.
 
  • Like
Reactions: gylka
So, turns out those batteries were in boot mode. So with the tool we've got (I don't know the developer) it removed all flags, turned off boot mode batteries started working as they should.
p.s. I'm sick and tired of these DJI batteries ****, there're always problems with them.
 
Anyone know what that “tool” is? Or similar? Seems like a handy thing to have…
 
Pretty sure it can be done with DJI Battery Killer, I didn't try to go in boot mode and turn boot mode off (should've tried), but I think it should solve it. I can't name tool I used because you won't buy it anyway, it's for military personnel only delivered hand to hand.
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
132,207
Messages
1,570,911
Members
160,961
Latest member
ggurta