Get more from your Mavic
The largest Mavic community in the world
Join Us Now

Mavic Pro - Forward Left Vision Sensor Error

Zane

Member
Joined
Dec 26, 2016
Messages
13
Reactions
1
Age
64
After crashing my Mavic Pro, I watched the YouTube videos and removed the top cover, and the camera, gimble as a complete assembly. I purchased new and installed and the camera and gimble work perfectly.

Although, now, I'm getting a left vision sensor error. I watched all the YouTube videos on how to correct and I can't get the red square box from the front of the drone that projects the red square image on the DJI, Assistant 2, dotted screen with the blue box on the PC.
Therefore, I'm unable to calibrate the two front and bottom sensors on the drone in order to remove the error message on my DJI, Crystal Sky monitor screen at first start up of the drone.

Can anyone help ?
 

Former Member

Well-Known Member
Joined
Dec 20, 2016
Messages
14,014
Reactions
13,090
Location
Duluth, Georgia
Make sure your left vision connector is plugged in tightly. It goes from the sensor to the gimbal PCB. Also, make sure there are no bent pins on the connectors from the vision sensors.
 

Zane

Member
Joined
Dec 26, 2016
Messages
13
Reactions
1
Age
64
Also, just wanted to let everyone know that the Mavic Pro flies like a dream in both normal and sport modes. It also connects to the satellites and flies in the Green GPS mode but the error message keeps taking over and showing up on my monitor as well as my controller screen. I can literally do everything in the past, prior to the crash, but I'm sure my sensors both front and bottom are no longer working correctly due to this error.
Flight wise, the drone is fantastic and camera and gimble are working perfectly again !
 

Zane

Member
Joined
Dec 26, 2016
Messages
13
Reactions
1
Age
64
Thanks Rob for the info. I checked the plug and pins in the left plug and everything looks good. I felt a "snap", when I plugged it to the gimbal bord but I still get the error message. I'm going to have you send me a new, replacement front sensor. If that doesn't work, I'll send the drone to you for repair.
 

sTvEx

New Member
Joined
Nov 5, 2018
Messages
1
Reactions
0
Age
27
Any updates on this? Ive also replaced the front sensor it's the same for me
 

Wanbli

Well-Known Member
Joined
Mar 1, 2019
Messages
77
Reactions
32
Age
71
Location
Charlottesville Area
Does anyone have a fix for this? I've tried everything I could find and nothing fixes it.
I've replace the front sensor array, the gimbal control board, checked all connectors, refreshed the firmware via Asstant 2, performed a restore to factory. NOTHING FIXES THIS ERROR! VERY FRUSTRATING 😤
 
Lycus Tech Mavic Air 2 Case

New Threads

Forum statistics

Threads
103,902
Messages
1,203,706
Members
132,591
Latest member
Jeepman