DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

MP Pro Apparently no Camera/Gimbal Connection


Active Member
Apr 17, 2017
I haven't flown in a while, a couple of days I updated everything, but I didn't fly. Today, when trying to demo it for a friend, it worked as far as flying, but I could never get it to really recognize the camera. The Shutter speed, EV, and all camera settings showed N/A. It showed no SD card when there was one present. The gimbal controls did nothing. I couldn't move it up or down. It was blurry, I couldn't switch to manual form Auto. There was no communication with the camerta, except the blurry picture from a weirdly pointed gimbal that kept flashing. Never crashed or dropped. The last time I used it, it worked perfectly. Could this happen from an update? Any suggestions?

Yes you can try rolling it back 1 version and see if it helps.

BTW, make sure when you are updating the FW that the drones cooling fan is working. You can hear it kick on at around 110°

Good luck.
When I use the DJI Assistant, it doesn't populate the list of previous versions. I tried doing a factory reset and that reports as failed. Can it be reset from the controller?
When I use the DJI Assistant, it doesn't populate the list of previous versions. I tried doing a factory reset and that reports as failed. Can it be reset from the controller?
Ensure you are using the latest DJI Assistant as available on the DJI website. On older version the list will not populate.

Ensure you are using the latest DJI Assistant as available on the DJI website. On older version the list will not populate.

Thank you for this. Once, I updated DJI Assistant, I was able to see previous versions. I tried to refresh the current version, and that failed. Then I tried to downgrade to another version, that failed too. Now, I want to try a factory reset, but I can't get the PC to recognize it now (which may be the reason for the failures.) I am really disappointed in this product and this company.

I was with a friend who was thinking about getting one, when he saw this happen on Sunday, DJI lost a sale. At least something good came out of it.
Hi, have you tried a different cable, it happens with some cables as the cannot transmit the data at a high enough speed.

i use a specific date cable when i connect any drone to DJI Assistant.
I tried 2 different ones, but I'll try a some more tonight.

Thank You
Well, I hooked my MP to my laptop, new computer, new dji assistant install, and new cable. I was able to see the previous versions. At least I could do that.
  • I attempted a refresh again of the current version, and that failed
  • I did a factory reset, it seemed successful but it didn't change anything (I guess I don't know what that does because it didn't change the Software Version)
  • Then I downgraded to a previous version . This too failed. It stops at 40% and the MP seems to shut off. I thought it was just rebooting as part of the downgrade but after about 2 minutes, it reports failure.
  • I thought about trying to replace the camera, but with all the trouble I am having trying to downgrade/refresh, I am thinking that maybe there's something really wrong.
Does anyone know how much money it costs to send this to DJI for repairs? Is it worth doing or should I sell it for parts and let the sun set on my drone activities.

I have $1500 in this and I had it for whopping 16 months, that means I have paying $100 month and I didn't fly for half of those. I can't believe DJI gets away with this.
I am sorry I am not able to help further. With me being in South Africa and you somewhere on the other side of the globe it is hard to attempt to assist without seeing and inspecting your drone.
I contacted DJI Care and they basically suggested the same things. The one thing they added was to try updating the RC by plugging into the PC. I didn't know that was a thing I could do, or maybe I did a long time ago. Nevertheless, it didn't work. I tried late Sunday night and the failures were the same. They initiated a support ticket for me to send in the unit for repair.

I was contemplating it, I'd prefer to send to Thunderdrones just for all the free support offered by them on this forum. I'd rather support them. I figured the problem was either really bad, like a fried PCB or something really stupid simple. It turned out that it was really stupid simple.

SOLUTION: It was the SD card. In addition to the lack of gimbal control, N/A displaying on the Shutter Speed, ISO, WB, etc it also showed no SD card, which was installed. Through one of my attempts at reinstall, I noticed that, one time, ALL it displayed was a SD Card with a line through it, no other camera traits at all. I thought it was just a variant on the same gimbal/camera problem I'd been having all along.

As I was preparing my email to Thunderdones, it occurred to me that I never tried taking out the SD card. Then I did that, and everything immediately worked. I pulled a few images off the card, which were from over a month ago, I don't even remember if I did that at the time. I formatted the card, reinstalled it, and everything went back to normal. I still need to fly and test it, but you just kind of know when the problem is probably fixed.

It's probably common knowledge, but from now on, at the first sign of odd behavior I am pulling the SD card. In PC repair, we always used to pull USB devices, Printers, etc and then add them back to locate issues. I should have known this, but it never occurred to me throughout this ordeal that the SD card could wield so much power.

I thank everyone for their input on this. I wanted to bring this to conclusion to help out anyone who HAS this issue or has to help someone with this issue. I'm looking at you Thunderdones :) I really appreciate of all of your effort, not only in this issue, but on this forum in General.
Last edited:

DJI Drone Deals

New Threads

Forum statistics

Latest member