DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

No camera image on a refurb ProThere

Iwf

Member
Joined
Jan 28, 2018
Messages
24
Reactions
6
Age
56
Just want to check I’m right about a camera problem on my ‘new’ pro.

Ive recently taken delivery of a refurbed pro. However I’ve got no camera signal. I’ve tried different cables, we card, different phones and different apps. There’s no issue with the gimbal and other than the camera image the pro flies normally. Notably its not possible to a take a photo or video. Most interesting though is the dji app can’t connnet to the camera to look at photos stored on the camera, giving a camera disconnected message.

To add to my problems i had a friend bring the pro in from the states so I’ve missed my 14 day return window. On arrival the gimbal clamp was not secure, so I’m thinking something’s come loose or its a broken video cable.

before i even think about taking it apart does anyone have any other ideas? I cant see an visible damage.



Cheers
 
Last edited:
Which port are you using for the connection from the RC to the mobile device? There are two, one on the left hand side (micro usb) and one at the bottom (standard usb). You could use either but only one at a time, meaning that the cable going into the side port must be disconnected if you are using the bottom port and vice versa.
 
Yep, I tried both. The middle one with a tablet and side one with my iPhone
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
129,899
Messages
1,547,293
Members
158,965
Latest member
lepermessiah70