DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Started recording video, lost all control and video telemetry

Crouching Leopard

Well-Known Member
Joined
May 14, 2020
Messages
417
Reactions
322
Age
69
Location
Glen Waverley Australia
A couple of days ago, I took my MM1 out for a fun flight. The previous day I had been out, did about 3 batteries of flying with no issues.

However, yesterday afternoon, everything was ok until I pressed video record. Within a couple of seconds, the phone screen greyed out, the controller continued to allow me to control for a few seconds, then stopped all control and lost connection, only returning intermittently, which confused me but I pressed RTH and it eventually did RTH land. Note, I was only about 15 Metres away, about 8-10 metres high, and in the centre of a very large and empty double-sized sports field.

I checked the drone over, no issues, rebooted the phone, controller, and drone, and took off, being wary of what had just happened. Flew out with video running but as soon as I got to the same distance and height, the same thing happened again. Note, I was definitely logged into the DJI site in the fly app and the weather was flying perfect, sunny with almost 0 wind. This happened no matter what direction I flew in.

After some failed attempts, got the drone back through RTH. Scratched head. As an ex-Military Radar, communications and computer systems maintenance, design and development engineer / Project manager, I know something about weird electronic behavior and was determined to try and figure this out. I swapped my flight phone (yes I have a dedicated phone just for flying), and used my regular phone which is also loaded with the fly app (usually this phone is turned off when flying). Same issue at almost exactly the same height and distance. but managed to manually fly back the short distance.

Put my last battery in and took off with the regular phone back in use. After a few meters, turned the recording on. The same issue again, so after about 1 minute I decided to go home and look in the forums. I pressed RTH. The drone came back but this time the drone just hovered above my head (I always use RTH land). Nothing I could do would bring it down or maneuver it, including canceling RTH. Then the situation turned tragic and gruesome.

Now I like bees, I really do. I never use pesticides in my garden, I grow bee attracting flowers and if they swarm in my yard, I just close the doors till they move on. After hovering for about 1 minute, a swarm of bees decided to attack/were attracted to my drone. Hundreds of them. The sound was like a chainsaw cutting through the swarm. I hated it but trying an emergency prop stop, cursing and fist-waving had no effect. Around 20 minutes of Bee carnage took place until the battery ran out and the Lewis Park genocidal Bee murderer HARD landed! Needless to say, I had a gruesome cleanup job to do last night. However, on checking the SD card, Photos but NO VIDEO on the card, but the controller had indicated recording??

So, after the cleanup, I did a complete factory reset of the drone and controller back to their "roll out" firmware and also the phone, and checked the drones data file. I never had less than 13 satellites and the data indicates forced landing.

Today took it out for a test to the same location. Same issues!! Turn on video record, lose control. I changed the sd cards and reformatted them. I also "in the field" "upgraded" back to the firmware operating the previous day when the trouble had started. In effect, the drone was back to its state when the problems started. But the problems remained.

Having booked in the drone for a service, I determined that my engineering days were definitely at an end. However, I then landed the drone on its way back and, for some reason, changed the video resolution from 2.7k to 1080 and took off. IT WORKED. Full control, distance out to 85 - 100 metres and 20-30 metres height AND RECORDING !!??. I then switched back to 2.7K and ran the full sweet of built-in auto maneuvers. Full recording and No Problems. Another 20 minutes of trouble-free test flying took place with perfect response. My "Old" baby bird was back!

The drone is still going back to my local service centre but has anyone else ever encountered such erratic behavior. Until yesterday I have never had so much as a single blip in performance and don't believe it was suburban wifi related as I have flown there many times and saw no telltale signs of video breakup. As I said, the drone was never more than 18-20 metres away when the problems occurred. My gut feeling is that somehow, overnight the firmware in either the drone or the controller became corrupted as they charged, but that does not answer everything.

As for the Bees, R.I.P ?
 
Last edited:
  • Like
Reactions: BuddhaGeek
Try formatting the SD card. I know it sounds odd, but i have seen similar issues in the past, and doing that fixed it.
 
What version is your DJI fly app? The latest 5th November release from DJI is causing flyaway/crash problems with quite a few MM owners and many have downgraded to the earlier version which is working just fine. Just a thought!!
 
Thanks for the replies. Tried the formatting trick. The problem remained until I switched video recording to 1080 the back to 2.7k. Could have been an issue in the recording function

To LastRexKing. What part of Yorkshire. Originally from Beverley.

The Fly app is version v1.2.0 on my flying phone and version 1.1.5 on my regular phone. I tried using both phones and the problem persisted. When testing yesterday I had the issue on both phones till I switched video resolution to 1080 then back. I will test again today on both phones

A couple of weeks ago I did try out a GPS spoofing app on my flying phone but removed it a couple of days later after seeing no difference. I also did some spring cleaning of old apps and cache removals on my flying phone (but not the flying apps) Maybe it switched something in the controller that had no impact until a "perfect storm" of other factors came into play. My regular phone never had the spoofing app, but does have a (normally turned off) VPN.
 
Last edited:
Try formatting the SD card. I know it sounds odd, but i have seen similar issues in the past, and doing that fixed it.
Hi LastRexKing
What part of Yorkshire. I am originally from Beverley. Wish I had Yorkshire countryside to fly in these days, The dales and Holderness, North York Moors (if allowed) Hornsea, Bridlington Scarborough, Filey, Flamborough and Danes Dyke just to name a few. Mouth drools just at the thought of it.
 
Hi LastRexKing
What part of Yorkshire. I am originally from Beverley. Wish I had Yorkshire countryside to fly in these days, The dales and Holderness, North York Moors (if allowed) Hornsea, Bridlington Scarborough, Filey, Flamborough and Danes Dyke just to name a few. Mouth drools just at the thought of it.
Hiya - not too far from Beverley. I’m in Carlton near Selby. It’s all very flat and boring farm land around here. Although I’m in North Yorkshire I’m about 45 minutes from anything interesting.
I love Danes Dyke - we generally go there a lot in summer as it’s the only dog friendly beach during high season, and there’s a great chippy on the way home. Unfortunately, the bigger seaside towns are now mostly unpleasant. Whitby and Filey are still nice enough, but Bridlington and Scarborough are awful. We prefer places like Robin Hood’s bay and Staines, or to drive up to Northumberland to Bamburgh.
 
Update on the status of my Mavic Mini fault from the service centre.

Last Friday, received an email from the DJI national service centre here in Melbourne asking me to upload the entire video cache and flightrecords folder to google drive for them to analyse.

Yesterday afternoon (Monday), I received another email saying that they had analysed the data and that the issue was a non-pilot error, that the core board module (FCC) had malfunctioned which caused the loss of control issue and hard land resulting in a broken front left handleg.

Although I am on care refresh and still on 2 replacements, they are going to repair the drone under warranty. As it's pretty close to my home, I can collect my baby bird later this week

It does bring one thing to mind though. Like any aircraft, things can just malfunction for no apparent reason, or as a result of something that happened weeks or months ago (Aircrash Investigation watcher and retired Air Force Engineer) which is why as pilots we should try to avoid the temptation to fly in an unsafe manner "expect the unexpected".

You might pay more, but you get service. DJI ?
 
Final note on this episode. Collected the drone from the repair centre.

Not a repaired drone, but a brand new drone and controller!! Complete with all the "remove before flying" stickers'.Brilliant

Straight away Took it for a very safe and very slow test flight, in a local football park. In the air for 5 minutes, and again attacked by bees!. No damage and only a few hits but back to drone reality!

The lesson, fly high(er) and fast(er) and land quickly this time of year, leave the bees behind
 
That's an interesting story with a lesson in caution if you first encounter a potential control issue. I'm curious as to why you always use a RTH landing, as manual should be far safer in the event of say a home point error.
 
It was the comment where you said you always use RTH land that caught my attention, not RTH when you'd intermittently lost connection on these problem flights. Glad you've sorted the issue now.
 
I had a similar, but not so many issues as you, problem. I was flying about 70 feet away and 100 feet high with 92 % battery when the drone went into emergency landing right where it was, above some outside diners. I had very little control of the drone but did eventually bring it back safely. The logs showed the erratic flight the drone was making because of the control issues but did not give reason for drone to perform emergency landing. I had previously had problems with drone not maintaining speed to the point where the logs said, "crash imminent" due to loosing speed. I also had drone going into cargo mode by itself. Long story short, it was the propellers. The Mini has some very thin propellers and they were a year old. There was no physical damage to them they had just flattened out. Put new ones on and all problems gone.
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
130,061
Messages
1,548,842
Members
159,114
Latest member
Gamecore