DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Strange problem with Litchi Waypoints

EddyK

Member
Joined
Nov 19, 2021
Messages
15
Reactions
6
Age
71
Location
United Kingdom
I'm having a problem with Litchi Waypoints that I can't figure out, and I hope someone here can help.

I keep trying to set a waypoint mission on an 'altitude above ground' basis, but Litchi won't let me. I do all the waypoints, use 'select all' then 'edit' and then choose 'altitude above ground', then 'OK', but then I get a message saying that the altitudes cannot be calculated because I'm not connected to the Internet. Then the message tells me to either connect to the Internet or choose another altitude option. But the thing is, I AM connected to the Internet when this happens. I've tried several times, each time checking I'm on the Internet, but the same thing happens. I connect to the Internet via Wi-Fi, and I've used three different Wi-Fi sources (in supermarkets, etc, as well as my EE Wi-Fi at home) with the same result. Tried resetting my tablet. Tried reinstalling Litchi. Tried using my other tablet. Nothing works.

Can anyone advise please?
 
Hum.

I have many questions.

How familiar are you with litchi?

Do you use the hub to create your missions?

What are you using for a mobile device?

What are you flying?


You will get help on this.
If I can't somebody will. :) 👌

Rod ..
 
I'm very familiar with Litchi but haven't used it recently.
I use a Samsung Galaxy A7 tablet Lite running Android 13 as my mobile device.
My aircraft is a DJI Mini 2.
I never use the hub.

Thanks for taking the time to answer this query.
 
  • Like
Reactions: RodPad
Thanks for replying. Thumbswayup

I only use the hub, I cant imagine using a mobile device to plan a mission.

Rod ..
 
Thanks for trying to help, Rod.

Just one more piece of information that might help people here: my version of Litchi says it's 'v4.26.6-g'.

The weirdest thing is, this happens with both my tablets (both are Samsung Galaxy A7 Lite). There's no doubt that I'm connected to the Internet when I try to do this altitude from ground procedure, because I can move the map to anywhere in the World and I still get a detailed satellite.

Just to be absolutely clear this is the message I keep getting:

"Failed to calculate altitudes relative to ground. Reason: Internet is required to calculate altitudes relative to ground. Please connect to Internet or change to a different altitude mode".
 
Last edited:
  • Like
Reactions: RodPad
...I keep trying to set a waypoint mission on an 'altitude above ground' basis, but Litchi won't let me...I get a message saying that the altitudes cannot be calculated because I'm not connected to the Internet

...But the thing is, I AM

...I connect to the Internet via Wi-Fi, and I've used three different Wi-Fi sources (in supermarkets, etc, as well as my EE Wi-Fi at home) with the same result.
This is very likely not related to anything in Litchi, instead something in your phones or tab which is blocking the communication with the ground elevation server... might be some security/anti virus app you have which contain a firewall, or some ad blocking app.

Have replicated your process with Select all + Edit + changing relative height from default "Home" to "Ground... and all is working as it should both with my home WiFi & mobile data... when I turn off both WiFi & mobile data, then I get the same message as you.
 
  • Like
Reactions: RodPad and DJ Wes
Thanks to everyone who has been trying to help me with this.

Working on the theory that some sort of adblocker or security setting on an app might be preventing Litchi from communicating with the ground elevation server, last night I did a factory reset on my tablet, removing all apps and all data.

I then reinstalled Litchi, so all I have on the tablet is Litchi and the few apps Samsung and Google automatically install. But I'm still getting this message.

Is there anyone who uses Litchi with the Samsung Galaxy Tab A7 Lite and can think of something I'm missing here? Thanks.
 
  • Like
Reactions: RodPad
Hum, well mind set is usually what has changed since it worked correctly.

Same Tablet?
Same Bird?

Rod ..
 
Hi Rod
No, different tablet and bird. I bought Litchi when I had a Mavic Pro and I was running it with a Google Nexus 7 tablet. I sold it an got a DJI Mini 2. It needed a different DJI app to fly it with, and this new app wouldn't work with my Nexus 7 because it needed a 64 bit OS. That's why I bought the Galaxy Tab A7 Lite.

The altitude feature definitely worked when I had the Mavi Pro running with the Nexus 7, but this is the first time I've tried using it with my present setup.
 
  • Like
Reactions: RodPad
There we go!
I still can't help you out.

Somebody here must have got some new info.👌

Rod ..
 
You have to check "Use Online Elevation" in "Mission Settings".

View attachment 173487
Was my initial thought also... but no, that doesn't generate below message.

"Failed to calculate altitudes relative to ground. Reason: Internet is required to calculate altitudes relative to ground. Please connect to Internet or change to a different altitude mode"
 
  • Like
Reactions: RodPad
Could it be that it is having issues with getting the elevation DEM data from Google Earth? I know in LVM that Namirda pays for a certain number of monthly DEM downloads for all of us to use, so could that have something to do with that? Or perhaps your virus protection settings are preventing the DEM download?
 
  • Like
Reactions: RodPad
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

Forum statistics

Threads
131,725
Messages
1,565,656
Members
160,579
Latest member
Ron613