Get more from your Mavic
The largest Mavic community in the world
Join Us Now

Troubleshooting Video Feed after Crash

Mpnapoli1

New Member
Joined
Jun 21, 2018
Messages
1
Reactions
0
Age
46
Newbie here so i will apologize in advance.... spent about 4 hours researching last night all the different forums and just looking for any additional guidance before starting different repairs.

Problem? Drown crashed into a tree and fall approx. 40 feet. Slight damage to 1 leg was easily repaired but no video feed to phone. Drone is fully functional in flight as best as i can tell based on a quick visual flight. The gimbal fully calibrates and articulates. I can control it up or down with app or the RC. I do hear two slight clicks when on startup that i cant recall if i heard before.

Was unit in a crash? Yes

What have you tried so far? Disassembled gimbal/camera mount from Drone.... No immediate visual damage to cables... Need clarification on Ribbon cable vs PTZ cable... Which does what as i think that might help me further troubleshoot. Does ribbon cable control gimbal and PTZ cable control video? I did remove and reattach the PTZ from the circuit board as some forums indicated that can easily become undone. I did NOT start to take apart the gimbal intself to trace that cable back. I have formatted the SD card and tried to record or take photos based on forums. Nothing records. What is particularly odd is i cant start the drone recording from the controller or the app but then i cant get it to stop on either. I am also having trouble switching modes between video on camera which I don’t recall having problems before? My gut tells me full replacement of the PTZ cable with a new cable but many of you have so much more experience so thought i would hit the threads. I was going to just buy a new gimbal/camera assembly on amazon but it seems like something more basic based on the fact the gimbal appears to be fully functional. Thanks so much for the help!

What device are you using ( iphone , ipad, Samsung , etc)? iPhone 6s

What firmware are you running ( aircraft, remote controller)? 01.04.0300 for both

What Go app version are you using? Dji Go 4

Any modification?
(if so what) No

Did you change anything or install any apps? (if so what) No

Do you have a video or pictures of the problem? (if so post link) No
 

Jayfdee

Well-Known Member
Joined
Aug 26, 2017
Messages
166
Reactions
93
Age
70
Good detailed post which will help others help you. I am not knowledgeable enough but plenty on here who are.
My best guess would be the ribbon cable, you are obviously capable of dismantling etc,and the ribbon is inexpensive, that would be my first action.
Some people just post "No video feed help", and it takes about 5-6 responses to elucidate the problem.
Hope you get it fixed.
 
Lycus Tech Mavic Air 2 Case

DJI Drone Deals

1. Mini SE - $299
2. Mini 2 - $449
3. Air 2 (renewed) - $649
4. Air 2s - $999
5. FPV Combo - $1299
6. Mavic 2 Zoom - $1349
7. Mavic 2 Pro - $1499

Forum statistics

Threads
108,464
Messages
1,284,722
Members
139,234
Latest member
Air2thethrone