DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Trying to connect M2P to iMac with DJI Assistant 2

Skydriver

Active Member
Joined
Aug 23, 2019
Messages
41
Reactions
34
Location
San Diego, CA
I am traveling by car on vacation in Oregon. 48 hours ago I flew my M2P and all was well. This morning (in a new location) drone asked for a compass recalibration, which I did and controller said it was successful. But then a second error came up stating that the firmware was "mismatched". I noted that there was no video feed so assumed that the controller was not 100% connected to the drone. Called DJI and Agent One said use Assistant 2 with a computer to update or refresh firmware.(I am traveling with an iMac M1). I first tried Assistant 2--drone would not connect. Called back. Next DJI agent said try DJI Consumer Assistant 2 app--no connection.Called back. Next Agent said no, try DJI Assistant 2 For Mavic--but still no connection. Tried different C cable--no connection from drone to computer. Again, this is with a new iMac M1 running OS Ventura 13.4. Firmware on Drone is 01.00.0779 and controller is V01.01.0072. I checked and both firmwares are up to date. Appreciate advice of dealing with mismatched Firmware and/or how to connect M2P to computer using some version of Assistant 2. Thank you.
 
I think you need the "assistant 2 for mavic"
DJI Assistant 2 For Mavic - Download Center - DJI
and not the "assistant 2" but I use windows not IOS. Seemingly you have already tried it :(.
I don't understand why DJI don't make new versions backwards compatible but I am not a programmer.

Unless the mismatch message was more specific such a message often relates to the battery firmware not matching the drones firmware, did you try touching the message to see what options it gives. I normally ignore battery mismatched as I have access to several Mavic 2 and fixing a mismatch on one could lead to warnings with others.

Have you looked in the app to see what the drone and controller firmwares are, I think the relevant section is in the "about" menu.
 
Last edited:
The firmware message was most likely referring to the battery itself which I’ve seen quite often. I tend to disregard them when I’m out in the field and not at home. I’m more comfortable with firmware issues when close to my own internet system.
If you experience a screen issue, my first choice would be to try a different cable.
They do fail at times. Hope you get this resolved.
In the reading I’ve done here on this forum, the folks at DJI would be last on my list. Seems to be more information to be gathered in this forum from the people that are more hands on.
 
Assistant 2 for Mavic does not work with M1 Macs or any IOS 11 or above so I can't use it with the computer I have with me. As to firmware mismatch, not sure but there is a warning red ! next to the M2P firmware info so I assume that is the problem. With that warning, the drone will not start. I did try another cable. It is pathetic how poor DJI help is. Thanks.
 
It seems that there is no solution to use any version of Assistant 2 for a M2P with a newer MAC. Is there anyway to refresh or reinstall firmware on either the M2P or the controller without hooking them up to a computer?
 
For my fellow MAC users --I solved the problem but it was not easy. I first signed up for a free trial of Parallels software to run Windows on a MAC. Then downloaded the DJI Assistant 2 for Mavic (windows) installed and ran the program. After several failed attempts, the program finally refreshed the firmware. I started the drone but got the same mismatched firmware error message. So for fun, I removed the Smart Media Card, and the drone started up with no error messages. I then put in a different Smart Media Card, formatted it and everything worked. Why a particular media card produced that CANNOT TAKEOFF mismatched firmware error is a mystery to me. Hope this experience helps someone else.
 
  • Like
Reactions: patrickweiss
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
129,914
Messages
1,547,451
Members
158,980
Latest member
troublegum78