Get more from your Mavic
The largest Mavic community in the world
Join Us Now

Winch Surfin active track?

Badgersurfer

Well-Known Member
Joined
Feb 15, 2020
Messages
51
Reaction score
14
Age
66
Location
UK
I was trying to video a winch surfer using active track but it didn't seem to want to play ball. The speed of the surfer is about 20-24 mph and I had my MPP in standard mode which only flies at 18 mph. I thought if I went into Active track it automatically controlled the speed up to the 40mph without having to switch to sport mode. It locked on initially and then lost the tracking after about 4 meters. I was behind the surfer so wondered if the wake caused a problem. I managed to get some pretty good video from in front flying at an average of 20 feet, but I really would like to use the active track. He was wearing a black wet suit and the water was river so it was quite dark and this was only my second flight with the Mavic. Haha I was trying out the RTH for the first time which worked great. Then when i was over the river I pressed RTH gain and it tried to land in the river. A bit of a hairy moment the I realised I was pressing the top icon and not the middle one. So I quickly learned to use the RTH button on the remote. Pheeeww!!! Any help would be appreciated.