What's wrong with this picture? Brand new Mavic props?

Discussion in 'Mavic Pro Help' started by TheLightSpeed!, Nov 29, 2016.

  1. TheLightSpeed!

    TheLightSpeed! Well-Known Member

    Joined:
    Oct 12, 2016
    Messages:
    563
    Likes Received:
    226
    Is this something I should be concerned with?

    MSinger can you weigh in?

    I just bought these props, and I noticed this today when I looked at them for the first time... [​IMG][​IMG][​IMG]


    Sent from my iPhone using MavicPilots
     
  2. Vicrimo

    Vicrimo Well-Known Member

    Joined:
    Oct 13, 2016
    Messages:
    159
    Likes Received:
    42
    I wouldn't use the 1 on the second picture. Looks like the rivet wasn't installed properly.


    Sent from my iPhone using MavicPilots
     
    #2 Vicrimo, Nov 29, 2016
    Last edited: Nov 29, 2016
  3. msinger

    msinger Well-Known Member
    Approved Vendor

    Joined:
    Oct 12, 2016
    Messages:
    2,363
    Likes Received:
    966
    Location:
    US
    Ah, the rivet... I was clearly looking at the wrong thing in the pictures. You definitely don't want to use that prop.
     
    thefrisbee995 likes this.
  4. TheLightSpeed!

    TheLightSpeed! Well-Known Member

    Joined:
    Oct 12, 2016
    Messages:
    563
    Likes Received:
    226
    I just got that one? **** it


    Sent from my iPhone using MavicPilots
     
  5. thestone11

    thestone11 Active Member

    Joined:
    Oct 13, 2016
    Messages:
    28
    Likes Received:
    12
    Missing half of the Rivet
     
  6. TheLightSpeed!

    TheLightSpeed! Well-Known Member

    Joined:
    Oct 12, 2016
    Messages:
    563
    Likes Received:
    226
  7. NH Phantom

    NH Phantom Well-Known Member

    Joined:
    Oct 15, 2016
    Messages:
    60
    Likes Received:
    1
    GOOD CATCH Check all props for bad rivets!!!
     
  8. vashon100

    vashon100 Well-Known Member

    Joined:
    Nov 20, 2016
    Messages:
    95
    Likes Received:
    26
    Lot of scuffs and scrapes for being new.
     
  9. TheLightSpeed!

    TheLightSpeed! Well-Known Member

    Joined:
    Oct 12, 2016
    Messages:
    563
    Likes Received:
    226
    That's not a new one


    Sent from my iPhone using MavicPilots
     
  10. m0j0

    m0j0 Well-Known Member

    Joined:
    Oct 12, 2016
    Messages:
    484
    Likes Received:
    172
    Holy lost prop.. no way I would fly that prop. Looks like it is begging to come off in flight.


    Sent from my iPad using MavicPilots
     
Loading...
Similar Threads - What's wrong picture Forum Date
What's wrong with this video? Photos and Videos Dec 4, 2016
What's up from Shreveport La Pilot Check In Yesterday at 10:52 PM
What's the USB port on the bottom of the mavic RC ? ? General Discussions Jan 6, 2017
What's up with the slow speed? Mavic Pro Help Dec 29, 2016
What's with this Jello? Do I need to get my Mavic replaced? Mavic Pro Discussions Dec 17, 2016

Share This Page