Welcome Mavic Pilot!
Jump in and join our free DJI Mavic community today!
Sign up

Crystal Sky won't connect - Help

ejmcompany

Member
Joined
Oct 19, 2017
Messages
18
Reaction score
3
Age
54
Hello...

I have a 7.85" Ultra and had been using it attached to my controller with no issues. I have been unable to fly for a month and today I am on vacation and pull out the drone and now the Crystal Sky won't find the drone. Everything seems to be connected properly and nothing has changed since my last flight. So I am unsure what gives? Ideas?

I have turned everything off and on several times and unhooked the Crystal Sky and the hooked it back up and same result.
 

Dronason

Well-Known Member
Premium Pilot
Joined
May 22, 2018
Messages
132
Reaction score
25
Age
57
Location
Switzerland
Try to disconnect the USB cable at the RC, fully shutdown the CS, keep the RC on, power the CS again and after it is displaying the home screen, then insert the cable in the RC.
Check if there is an update. The last Go4 app version available for CS is V4.2.16 and is stable.
 

ejmcompany

Member
Joined
Oct 19, 2017
Messages
18
Reaction score
3
Age
54
Thanks... I am in a place with lousy wifi and was able to get the message to come on once about the update. I tried to do the update and it said I wasn't connected. I have repeated the process and am unable to get the update message again. Is there a way to directly connect the Crystal Sky to my laptop? I only have a usb as it is a surface pro 4.
 

Dronason

Well-Known Member
Premium Pilot
Joined
May 22, 2018
Messages
132
Reaction score
25
Age
57
Location
Switzerland
Not really possible to use assistant 2 for update I think.
What version of DJI Go4 are you using?
But if it was working before problem is probably more with the connectivity I would say.
 

ejmcompany

Member
Joined
Oct 19, 2017
Messages
18
Reaction score
3
Age
54
Well I was able to use a micro SD card in my computer to download the update. That is the good news however still not connecting to the drone. I have checked to make sure the download worked and the Crystal Sky now reads 4.2.16.
Any other ideas?
 

Dronason

Well-Known Member
Premium Pilot
Joined
May 22, 2018
Messages
132
Reaction score
25
Age
57
Location
Switzerland
Did you try some other cables and to power up first the RC, then CS (from full power down, not just sleep) and then connect cable to CS and finally to RC?
I had the case one time where it was the only way to establish the connection. No real idea why, somehow the CS started something related to the RC too early during its boot and when the GO4 app was manually started, nothing happened. If now I try to reproduce the issue I had, I cannot. With cable connected, if I power up the RC, then the CS turn on and Go4 is launched and I can connect.
 

New Threads

Forum statistics

Threads
70,668
Messages
818,309
Members
97,798
Latest member
PartyLineLimo