Get more from your Mavic
Friendly, Helpful, Knowledgeable Mavic Community
Join Us Now

Gimble in a wreck

BillC_Utah

Member
Joined
May 4, 2018
Messages
9
Reactions
1
Age
78
Problem?I landed my 3 day old MP on the hood of my car and it slid off and hit the ground with the motors off - not running. Hood is not a good landing pad so lesson learned there.

Was unit in a crash? Well , think I covered that

What have you tried so far? Started it up and the gimble warning says maybe the gimble lock is on but it is not. Also, overload on gimble motor probably since it is not as free as it should be. Up down is OK but side to side doesn't feel as free as it did before. The 4 rubber mount bands look attached and free movement there.

What device are you using ( iphone , ipad, Samsung , etc)? ipad

What firmware are you running ( aircraft, remote controller)? Latest updates from 3 days ago

What Go app version are you using? DJI GO 4

Any modification?
(if so what) No

Did you change anything or install any apps? (if so what) No

Do you have a video or pictures of the problem? (if so post link) I have the DJI refresh and it may be best to send it in to them or Thunderdrones. don't have much experience in this area. I can send pics or ...what to look for. The cap with yellow tag has scratches on it and the cable seems to be rubbing the gimble left right movement. Not much impact from 2.5 ft but apparently enough.

Thanks to all. Bill C
 

Former Member

Well-Known Member
Joined
Dec 20, 2016
Messages
13,984
Reactions
13,061
Location
Duluth, Georgia
The gimbal clamp error message after a fall might mean that your gimbal ribbon cable got damaged, but also possibly a bent motor assembly.

I would recommend sending it off to DJI, especially if you have Refresh and it will only cost $79 this time.
 
  • Like
Reactions: ksmusa
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
116,850
Messages
1,384,762
Members
145,642
Latest member
saltydrone