DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Help re SD card and photo/video functions

Saigongal

New Member
Joined
Jul 26, 2020
Messages
4
Reactions
2
Age
59
Location
Liverpool/North Wales, UK
Hi Guys,

This is my first post as I am a brand new pilot, so apologies if it isn't in the right place. Please let me know if I need to re-post it in a different place.... thanks:
.
Problem?
Using Mavic Pro - I have several issues concerning the video, still photos and SD card. I am a novice and am finding this very frustrating as I bought the drone second hand and don't know if this is me doing something wrong or if the unit isn't functioning correctly:

Frequently the screen shows 'no SD card' but when I go to settings it says that the SD card is OK. At other times, for no apparent reason (I didn't change any settings that I know about), it says SD Card and allows me to format it.

The video function does not work consistently. At times it works fine, then other times (mostly) the red on-screen button remains white and the manual control button has no effect. 'Rec' does not show on the screen and there is no video on disk. Sometimes, the red on-screen button remains white and ineffective and the manual button also seems not to work, there is no 'Rec' on-screen but a video is on the disk when I check later.
The 'photo taken' sound sometimes does not work; the screen blinks like it may have taken a photo but I am never sure.

I don't think that I do anything different when the photo/video are working perfectly and when they are not.

Have tried different SD cards, including one new off the shelf and still no joy.

Just now I went to fly and it said No SD card and nothing would make it locate it; flew up and no red button or manual control for video, no photos; continued to fly and suddenly, for no apparent reason, red button and manual video control started and photos OK.

Is this the drone or just my lack of knowledge?

Was unit in a crash?
No

What have you tried so far?
I have been into settings to see if I can identify anything different there when it is/isn't working but it all looks exactly the same when the problem is there and when it isn’t.

I have watched numerous videos to try to understand how to work these functions but as I see it, it should be very straightforward.

I have deleted and reinstalled the app several times.

What device are you using ( iphone , ipad, Samsung , etc)?
Huawei P smart.
Model: FIG-LX1
EMUI version: 9.1.0
Android version 9

What firmware are you running (aircraft, remote controller)?
Latest Firmware, all up to date. I can’t actually find where it says the detailed info, it just says ‘latest firmwear’.
Remote controller – 01.04.0500

What Go app version are you using?
DJI GO 4

Any modification? (if so what)
No

Did you change anything or install any apps? (if so what)
No

Do you have a video or pictures of the problem? (if so post link)
No
 
Hi Guys,

This is my first post as I am a brand new pilot, so apologies if it isn't in the right place. Please let me know if I need to re-post it in a different place.... thanks:
.
Problem?
Using Mavic Pro - I have several issues concerning the video, still photos and SD card. I am a novice and am finding this very frustrating as I bought the drone second hand and don't know if this is me doing something wrong or if the unit isn't functioning correctly:

Frequently the screen shows 'no SD card' but when I go to settings it says that the SD card is OK. At other times, for no apparent reason (I didn't change any settings that I know about), it says SD Card and allows me to format it.

The video function does not work consistently. At times it works fine, then other times (mostly) the red on-screen button remains white and the manual control button has no effect. 'Rec' does not show on the screen and there is no video on disk. Sometimes, the red on-screen button remains white and ineffective and the manual button also seems not to work, there is no 'Rec' on-screen but a video is on the disk when I check later.
The 'photo taken' sound sometimes does not work; the screen blinks like it may have taken a photo but I am never sure.

I don't think that I do anything different when the photo/video are working perfectly and when they are not.

Have tried different SD cards, including one new off the shelf and still no joy.

Just now I went to fly and it said No SD card and nothing would make it locate it; flew up and no red button or manual control for video, no photos; continued to fly and suddenly, for no apparent reason, red button and manual video control started and photos OK.

Is this the drone or just my lack of knowledge?

Was unit in a crash?
No

What have you tried so far?
I have been into settings to see if I can identify anything different there when it is/isn't working but it all looks exactly the same when the problem is there and when it isn’t.

I have watched numerous videos to try to understand how to work these functions but as I see it, it should be very straightforward.

I have deleted and reinstalled the app several times.

What device are you using ( iphone , ipad, Samsung , etc)?
Huawei P smart.
Model: FIG-LX1
EMUI version: 9.1.0
Android version 9

What firmware are you running (aircraft, remote controller)?
Latest Firmware, all up to date. I can’t actually find where it says the detailed info, it just says ‘latest firmwear’.
Remote controller – 01.04.0500

What Go app version are you using?
DJI GO 4

Any modification? (if so what)
No

Did you change anything or install any apps? (if so what)
No

Do you have a video or pictures of the problem? (if so post link)
No

Hi

The first thing I would do is downgrade the firmware to 01.04.0300, it was a more stable FW, I would use a program called Drone-Hacks from the link below, its free to flash firmware, DH uses a better system to flash and error checks, the DJI assistant just throws the FW at the quad and lets it get on with it.

Once flashed see if the issue occurs again.


 
Hi Saigongal Welcome to Mavic Pilot

What rating is the SD card you are using, is it fast enough U3
If you haven't already have a good read of the manual it will solve some if not all of your problems.
Download Mavic Pro manual HERE
 
  • Like
Reactions: Saigongal
Hi

The first thing I would do is downgrade the firmware to 01.04.0300, it was a more stable FW, I would use a program called Drone-Hacks from the link below, its free to flash firmware, DH uses a better system to flash and error checks, the DJI assistant just throws the FW at the quad and lets it get on with it.

Once flashed see if the issue occurs again.


Thanks for this - its all a bit technical for me at the moment but I'll go through it and see what I can do - maybe have to come back to you for an explanation of some of it!
 
  • Like
Reactions: Exphantomflyer
Hi Saigongal Welcome to Mavic Pilot

What rating is the SD card you are using, is it fast enough U3
If you haven't already have a good read of the manual it will solve some if not all of your problems.
Download Mavic Pro manual HERE
Hey thanks for the manual - I was of course like a small child anxious to play with my new toy so I will now sit down and go through the manual (which I didn't even have!) and hopefully get sorted! :)
SD Card - one came with it, and I bought two more specifically for 4K video. Hope that is right!
 
  • Like
Reactions: THE CYBORG
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

Forum statistics

Threads
130,932
Messages
1,558,061
Members
159,941
Latest member
jonesaerial