Welcome Mavic Pilot!
Jump in and join our free DJI Mavic community today!
Sign up

Lost signal issues

JeanVos

Well-Known Member
Joined
Jan 29, 2018
Messages
64
Reaction score
4
Age
54
Location
South Africa
Hi,

I have been getting intermittent lost signal black screens. This happens even when I am very close (<300m) to "home". If I unplug from the iPhone 7+ and plug back in I get it back. If not, unplug again and then it reconnects. Any ideas?

Regards
JeanV
 

FalconLight

Active Member
Joined
Jun 19, 2018
Messages
29
Reaction score
15
Location
Netherlands
Hi,

I have been getting intermittent lost signal black screens. This happens even when I am very close (<300m) to "home". If I unplug from the iPhone 7+ and plug back in I get it back. If not, unplug again and then it reconnects. Any ideas?

Regards
JeanV
Did you plug in to the left side of the RC?
If so, change the cable. Better solution is to use the bottom USB.
 

cyclonite

Well-Known Member
Joined
Jun 28, 2018
Messages
50
Reaction score
17
Location
Kikatinalong
Yeah Im getting exactly the same issues using an ipad mini4
I use the bottom USB port and disconnect & reconnect from the ipad side connection.
Pain in the Rs.
 

KeithLa

Well-Known Member
Joined
May 29, 2018
Messages
191
Reaction score
87
Age
48
Location
Bellevue, Washington
Same issue awhile back, using Android phone. Resolved entirely by always using bottom port with high quality cable.
 
DJI Drone Service

New Threads

Forum statistics

Threads
71,658
Messages
830,402
Members
98,706
Latest member
Defo2311