Welcome Mavic Pilot!
Jump in and join our free DJI Mavic community today!
Sign up

Pixelated Video ... then Freeze ... then No Video

Joined
Jul 22, 2018
Messages
9
Likes
1
Age
52
#1
Originally posted on Mavic Pro Platinum, but got no responses:

I am completely confused here.

After doing a sensor calibration (due to an error I was getting that Precision Landing required a sensor calibration) ... I took the Mavic Pro up today and started seeing some pixelation ... then the video froze ... then absolutely no video at all!!! I've since tried powering-on and off; different cables to my iPhone X ... and the problem persists.

What am I missing here? Or is this a legit hardware issue requiring servicing?
 
Joined
Jul 22, 2018
Messages
9
Likes
1
Age
52
#3
I hope you're joking Cyclonite

In either case ... I just set the Image Transmission Settings to 'CUSTOM' and slid it to a weak signal interference ... and for now, inside my office, the image is being received onto my attached smartphone. Let's see if this works tomorrow outside
 

cyclonite

Well-Known Member
Joined
Jun 28, 2018
Messages
51
Likes
18
Location
Kikatinalong
#4
No Im not joking and its not funny.
The only clowns around here are the coders at DJi
If you look about youll see plenty of work arounds, some simple, some not so, some seem to work some not.
Either way this is not good.
 

jason38

Well-Known Member
Joined
Dec 31, 2017
Messages
156
Likes
76
Location
Isere, France
#5
Yes, DJI GO 4 is very crapy....
And its very diapointing when you bought a 1200$ drone...

If you tap "go4 issues" in the search area, you'll see what we are talking about...

Thats kind of "funny" to see that EVERY people flying a dji product has allready get issues with that app.... And that DJI seems to not even give a ***** to solve it....
 
Joined
Jul 22, 2018
Messages
9
Likes
1
Age
52
#6
Are the issues generally about video/photo feeds between the Mavic Pro and the RC/smartphone?

One thing I noticed is that I can fly the drone just fine and adjust the gimbal with the RC ... even while the video feed is lost. So apparently it's not losing all communication with the drone
 

cyclonite

Well-Known Member
Joined
Jun 28, 2018
Messages
51
Likes
18
Location
Kikatinalong
#7
Who bucking knows?
Im new to drones so imagine the many others like myself that have to try and learn to ride the "broken bike" with nothing to compare too.

Seriously considering returning this ornament for my money back.
 

Mossiback

Well-Known Member
Joined
Oct 3, 2017
Messages
2,413
Likes
1,296
Age
64
Location
Brier, WA USA
#8
Are the issues generally about video/photo feeds between the Mavic Pro and the RC/smartphone? ...
The issues are with Go 4 and your display device; with an outside chance that your connection cable or connection port is faulty. It seems like Go 4 is getting more resource hungry with each new version, requiring more and more powerful display devices. This is probably why some devices have been dropped from DJI's approved list and why some devices worked fine before a Go 4 update and not after the update. To help your iPhone cope, turn off all other apps, place in airplane mode, free up as much memory as you can, and turn off caching. Downgrade Go 4 if needed to find a version that works for you and then turn off auto-updating so it will not change. This advice is normally reserved for the Android crowd but your iPhone X may be too old or weak for the current Go 4 version to work.
...Seriously considering returning this ornament for my money back.
Hang in there. It should not be required but is worth the effort.
 
Joined
Jul 22, 2018
Messages
9
Likes
1
Age
52
#9
My current device is an iPhone X with plenty of memory and space. I've also been closing all open apps AND running it in Airplane Mode.

STILL ... these issues occurred.

Now, as I mentioned above, last night I set the the Image Transmission Settings to 'CUSTOM' and manually slid it to a weak signal interference ... and for now, inside my office, the image was being received onto my attached smartphone. Let's see if this works later today outside.

I haven't tried to turn off caching, but I can try that too
 

cyclonite

Well-Known Member
Joined
Jun 28, 2018
Messages
51
Likes
18
Location
Kikatinalong
#10
Has anyone read the fine print regarding the mavic pro sorfware, firmware issues.
I wonder if they have clauses to relive them of any responsibility regarding this balls up?
 
Joined
Jul 22, 2018
Messages
9
Likes
1
Age
52
#12
Dang! The problem still persists! I saw one YouTube video that suggested replacing the camera lens ... hope it's not that.

Next I'll try replacing the SD card ... who knows
 

Thwyllo

Well-Known Member
Joined
Mar 27, 2018
Messages
639
Likes
308
Age
64
Location
Hautes Pyrenees, SW France
#13
Hang in there. It should not be required but is worth the effort.
It absolutely isn't. What other brand new consumer device needs to come with a box warning that says "May take several weeks to get working"?

The OP should throw it back for a replacement or try a model that doesn't have these issues - my comment about buying an Air wasn't tongue in cheek.
 

ac0j

Well-Known Member
Joined
Sep 17, 2017
Messages
2,678
Likes
2,017
Age
55
#14
The air has as many or more trouble threads than the pro’s. So that is not a fair suggestion.
Have you updated anything? Software’ firmware, IOS? If you have updated any of the above, you need to update all. Also if using the short DJI cable from the side of the remote, switch to a stock Apple cable in the bottom USB. Be sure to remove the side plug completely. Make sure you aren’t storing too much Mavic video to the phone. Delete older video files. Also, attach the drone to assistant 2 and format the sd card from there.
If it is a camera problem the video will be bad on the sd card in the Mavic too. So check the card video before you format.
 

ac0j

Well-Known Member
Joined
Sep 17, 2017
Messages
2,678
Likes
2,017
Age
55
#15
One more thing, Hard restart the phone if it has been powered on for a long time.
 
Joined
Jul 22, 2018
Messages
9
Likes
1
Age
52
#16
How do you know if the RC is up-to-date too? When I update the firmware, that's for the drone, right? So how does the RC get updated?
 

ac0j

Well-Known Member
Joined
Sep 17, 2017
Messages
2,678
Likes
2,017
Age
55
#17
It should happen at the same time. Connect to assist2 and make sure all is updated.
 

jag32266

Well-Known Member
Joined
Dec 1, 2017
Messages
113
Likes
23
Age
70
Location
30.11,-81.78
#18
This problem is well known under several different headers- pixelation, pixalation, lag, video loss, etc. Try this forum here- Suddenly having Lag/video pixelation? Fixed!
And seems mostly to be caused by the firmware update and how DJI is trying to keep all of the drones with the latest/greatest making more demands on the display unit. And doesn't seem to be OS dependent meaning both are having issues.
What seems consistent is rolling back the DJIgo4 app to an older version with 4.2.20 being the culprit.

What needs to be watched (and read about in the EUA) is the LATEST version- once you update to THAT dji has made it so you can never roll back to an older version as I read it.

I just rolled back my android to 4.2.16 and it did improve but not fix the issue. I'm planning to rollback further later today/tomorrow.
DJI TECHNOLOGY CO., LTD APKs - APKMirror

HTH.
 

ac0j

Well-Known Member
Joined
Sep 17, 2017
Messages
2,678
Likes
2,017
Age
55
#20
With Apple it is almost always a mismatch between firmware,software, and IOS. OR a bad cable connection. Android is poorly supported because of all the differences in android devices so rolling back is the easiest solution. If the iPhone X was working and now isn’t., I suspect the above solutions.
 

New Threads

Forum statistics

Threads
50,684
Messages
592,472
Members
74,963
Latest member
cheshirefamily