DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

RC1B compatibility

DVegaman

Well-Known Member
Joined
Dec 12, 2016
Messages
141
Reactions
70
Age
45
Location
NJ
Hello Everyone,

Epson/DJI claims that the latest DJI firmware released 7/7/20 allows us to now utilize our Mavic 2 RC1B transmitters. (Previously only able to utilize RC1A) Does anyone have the ability to verify this? I no longer have an MP2 or would test on my own. Thinking about picking up another and wanted to know my options. Any assistance would be greatly appreciated.
 
All I can see is the firmware version 1.7.0 which was released on the 15th of Jan 2020.

What version are you referring to ?
 
Hey lannes,

I don’t have a MAVIC 2 anymore but here’s a link below



I was told by a reputable source that the compatibility issue was sorted with the above firmware update. I trust but must verify. Can anyone help me out?
 
Last edited:
It is compatible with RC1A. (Older gen TX) RC1B compatibility was not possible until now? (Still need this confirmed)
 
It is compatible with RC1A. (Older gen TX) RC1B compatibility was not possible until now? (Still need this confirmed)
I could be wrong but it looks like a DJI firmware upgrade for the MP2/Zoom earlier this year made the BT-300 compatible with the RC1B.
 
Last edited:
I am working on this theory today, there is a update to the controller 01.00.0640/670 depending how up to date your controller is, my 1A only needs 640, but the 670 for the 1b. Its been a few weeks since I last flew (4th of July weekend) using my Epson bt 300's. Once I get everything charged up I will do the update via Youtube and post the result by tonight.
 
  • Like
Reactions: chuck1026
Didn't give our group any shout outs in your video for providing the lead. ?

We have upgraded our status to the "above ground rumor mill."

 
Last edited:
A year ago I purchased another RC1A so my glasses would work and placed the original RC1B brand new unused back in the box
Well today it’s back out updated and works with the glasses!
About bloody time!!
I put out a video last week about the update
 
  • Like
Reactions: Welsh pilot
So it’s safe to say that the MP2 & M2Z are now both compatible with the Espon BT-300? Will these also work with the Epson Soar App as well or just DJI Go 4???
 
Hi I am new to this forum and fairly new to piloting drones. I currently fly a Mavic Pro. I’ve spent some time researching FPV options and settled on Epson Moverio since it seemed to provide the best of both worlds.
I purchased a used pair of BT-350’s and set to work downloading software and hooking them up. However no matter what I try I cannot get them connected to the controller - which btw is the RC1b.
The Moverio kit is running Android 5.1 and i downloaded and installed 4.3.32 app from the DJI website. This is the same version that is currently available on the Moverio Apps site so I am assuming it should work.
I upgraded the firmware on both the aircraft and the controller to the latest version - I read that the RC1b required this to function.
I have tried multiple cables for both the USB A port and the mini USB port on the side.
I have tested using a tablet that both ports work with other devices and they do.
I noticed that when Moverio controller is connected to the Mavic controller that it behave like it’s just been put on charge, the lights on the front flash and the charge icon appears in the top rh corner.
I have tried turning on and off the developer options in the settings panel on the Moverio...
I have tried various power up routines, many, many cables and now I am out of ideas.
Sadly I don’t know anyone else that flies a drone let alone an MP so I don’t have another kit to try it on.
So I have two questions.

  1. can anyone spot the rookie mistake or suggest anything else I could try?
  2. are there any other pilots in my region (Wiltshire/Berkshire UK) who are running a Moverio solution successfully and who would be prepared to assist with some troubleshooting?
Thanks in anticipation of any replies
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
132,044
Messages
1,568,985
Members
160,827
Latest member
HeidiSue