DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Smart controller for M2Z firmware update horrors and happies

DVPOWERS

Well-Known Member
Joined
Nov 6, 2020
Messages
64
Reactions
71
Age
64
Location
San Jose, CA
I pulled out my M2Z and smart controller yesterday to get ready for today's flight. The controller gave a message - needed a firmware update to V01.01.0076. After one try I got an error message - needed more memory, can't do the install. After checking, I saw I had plenty of memory.. I checked youtube, and found nothing on the topic. I tried the DJI tech hotline phone number and after a little bit of a wait, I got a nice, patient, and knowledgeable person on the line. She walked me though a couple of things and then determined I needed to do a factory reset. After the factory reset, the SC happily took the firmware update. After bending over thanking the tech person far too times, I went out to give the drone a try. I got an "error 108" message, "cannot take off". I found this kind dude on youtube:
To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.
and followed his steps. Problems solved, the drone is up in the air and happy. Thank goodness for kind people who can walk me away from the ledge and give aid when I'm up against a wall.
 
  • Like
Reactions: VanP and mavic3usa
You also need to download and install the latest version of GO4 directly from the DJI website. I just looked on mine and the GO4 (app) version is 4.3.60 which seems to work fine. So, in addition to the aircraft firmware update you also need to make sure you have the latest GO4 version. If you use Litchi you also need to make sure you have the latest version as well.
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
132,618
Messages
1,575,436
Members
161,322
Latest member
robaretoe