DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Transmission bug, and solution for better connection during flight.

Joined
Jan 15, 2023
Messages
21
Reactions
9
Age
37
Location
USA
I live in a moderately urban area, and had been really struggling with connection hiccups and random lag/dropouts (Mavic 3 with RC-N1 running on a Google Pixel 7). I figured it was due to interference. I'd initially set my transmission to "dual band", thinking the software would pick the best channel, but unbeknownst to me, the DJI Fly app was randomly switching itself to the 2.4Ghz band, and removing the option of dual band or 5Ghz, so regardless of what the RF in my environment looked like, it was defaulting to 2.4Ghz. To those who may not know, the 2.4Ghz frequency is incredibly congested in urban areas, and while it has its advantages, those are often outweighed by the disadvantages in these types of environments, namely the interference is awful. Anyway, once I realized this was happening, I struggled to find a solution. Eventually I found that by force closing the app via the Android multitask interface, and then relaunching DJI Fly, it brought back the dual band and 5Ghz options under the transmission tab. Then manually switching it back to either dual band or 5Ghz solved my problem and led to MUCH less interference during flight. I now check before every flight. It doesn't do it every time, but I'd say it happens 70-80% of the time, and I have to force close the app, relaunch, and change it back to dual band or 5Ghz.

I wanted to share this discovery in case there is anyone else out there experiencing this, or wondering why their reception is so bad. I've done a quick screen recording to illustrate what I mean, for anyone curious.

 
  • Like
Reactions: RadioFlyerMan
If 5Ghz is better, why not just keep it there all the time? Thanks for the post. I'm in a congested area, and I will try what you say.
 
If 5Ghz is better, why not just keep it there all the time? Thanks for the post. I'm in a congested area, and I will try what you say.
I wish that I could, but unfortunately that's the crux of my issue, even when I set it to 5Ghz, the next time I turn on and pair my controller/drone, it has automatically switched back to 2.4Ghz, and as I show in my video, it doesn't even give me the option to then switch back to 5Ghz without force closing the app and relaunching it.
 
I always thought that in congested areas, or areas with a lot of trees,... 2.4 ghz would be better. At least at home on my wifi, use 5g if it only needs to travel within a room or two, but it falls off fast if it has to go through a couple walls., so I would have assumed a stronger and further signal with 2.4ghz unless there are a lot of interference within a limited area.
 
I always thought that in congested areas, or areas with a lot of trees,... 2.4 ghz would be better. At least at home on my wifi, use 5g if it only needs to travel within a room or two, but it falls off fast if it has to go through a couple walls., so I would have assumed a stronger and further signal with 2.4ghz unless there are a lot of interference within a limited area.
2.4 GHz has better range and penetration (meaning it will go through walls and buildings better), but it is used by **** near every consumer electronic, and has limited channels. 5 GHz is a portion of the spectrum which was opened to consumer electronics more recently and has more channels. As a result it 5 GHz is far less congested. I've seen some tests on YouTube (specifically testing reception on DJI drones), and it appears that in populated areas the advantages of 2.4 GHz are largely negated by the congestion and interference. I haven't tested it myself, but I imagine if you were out in the desert, or somewhere sparsely populated you'd want to use 2.4 GHz, but in my situation of living in a populated suburb, I find that I get noticeably more stable reception with 5 GHz.
 
One suggestion that you could try and see if that might be the cause of your issue:
Once you have gone through pre-flight, sats/GPS locked and home point set - switch your phone to Airplane mode. BT and WiFi might be impacting the RC . . . . You do not need the phone's connectivity after the above.
 
One suggestion that you could try and see if that might be the cause of your issue:
Once you have gone through pre-flight, sats/GPS locked and home point set - switch your phone to Airplane mode. BT and WiFi might be impacting the RC . . . . You do not need the phone's connectivity after the above.
I'd missed your response to my issue back when I originally posted. Started running into this issue again recently, and while I had previously had luck with closing/relaunching the DJI Fly app, this time around I couldn't get the 5.8ghz band to appear no matter how many times I tried. I came back here and saw your solution. Bingo, totally worked! Definitely seems that the phone's WiFi was the culprit. Disabling it during flight seems to have solved the problem.

Thank you so much for your suggestion, I was really getting frustrated with the sporadic/constant disappearance of 5.8ghz in the transmission settings. Flying with it set to 2.4ghz is nearly unusable where I live due to interference.
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
130,022
Messages
1,548,448
Members
159,073
Latest member
OzoneTech