DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Video skipping while flying


Active Member
Jan 25, 2018
While I’m flying the video skips, stutters, and is jumpy. Even though this shouldn’t matter, I thought maybe because I was shooting in 4K and 2.7k so I tried lowering and it still happens. I even went out and bought a new memory card (San disk extreme pro vs the San disk extreme I was using) but that also didn’t help. I also tried turning off the video cache to the phone and also didn’t help. Any suggestions?

Here is an example from the other day
Dropbox - IMG_8277.TRIM.MOV
try switching to internal memory to see if it goes away - eliminates your cards all together
try switching to internal memory to see if it goes away - eliminates your cards all together

I’ve tried this as well. I don’t think it’s the card though because like I said I just purchased a brand new extreme pro card which should be more than enough speed to write.
What FW are you running? What version of DJI Go4 are you using and on what device?
It is on the live video and on the actual file. I could have uploaded the entire file but I trimmed it so you wouldn’t have to watch the entire thing.
Hey, I had the same issue today on my desktop. My video cache on phone was full so it didn't record my flights to compare. I used the internal storage to record on 4k 24 fps on MA, came back home and copied the files to my d drive and tried to pay the file, and it seemed like skipping a single frame. I thought something was up with my desktop so I tried it on my laptop and sure enough the skipping is gone. Try playing the files on another machine, if same result, try to play the videos from the internal memory of the drone straight I will update this thread with my findings tomorrow. It's 2:30 am here
UPDATE: make sure your player is using the right graphic card !!!. I had unplugged my pc the other day to do some cleaning, and as im done i re plugged the cable into the same exact slot i took it out from, but for some reason it took intel settings instead. I didn't realize that before updating the drivers on the graphic card. One of the 2 might be your solution.

DJI Drone Deals

New Threads

Members online

Forum statistics

Latest member