DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

What causes the gimbal to not yaw?

  • Thread starter Deleted member 103366
  • Start date
D

Deleted member 103366

Guest
I got hold of a flying Mavic mini with a non functioning gimbal, presumably crash damaged in some way, the camera works.
Ultimately I may use the drone for a CSC mid air motor stop and attempted restart so it very well may end up being destroyed but it will satisfy my curiosity in the process.

Any how, at boot the gimbal rolls and pitches during its dance but there is no yaw. A working Mavic Mini gimbal yaws slightly during the dance.
Once the drone has finished the boot the gimbal does nothing i.e. it does not correct for changes in the drone's pitch or roll. It is not switched to FPV mode.
I see a gimbal stuck warning coode 40002.
I can yaw the gimbal with my fingers and it feels free and smooth. That is with the drone powered off, I have not tried it with the drone switched on,

I am curious if any one knows what could be the cause?
 
Last edited by a moderator:
@PhiliusFoggg most likely a damaged data cable between the gimbal and the control modual
 
@PhiliusFoggg most likely a damaged data cable between the gimbal and the control modual
Is that the 3 in 1 cable or the signal cable? I would presume the 3 in 1 cable?

H0ac58e2f01364b9a96502bf89a80bc828.jpg
 
3 in 1.
The 3 in 1 cable you show connects to the circuit board in the gimbal that drives the gimbal's yaw motor.
The stranded cable does not connect to the gimbal's yaw motor UNLESS some data is sent up the stranded cable into the drone and then out through the 3 in 1 to the yaw motor's circuit board.
The stranded cable connects to the board of the gimbals' roll motor and to the actual camera, the gimbal's pitch motor's circuit board is fed by the gimbal's roll motor's circuit board.

I cut a scrap gimbal apart, I couldn't dismantle it.
 
Last edited by a moderator:
Thank you. i'll order a 3 in 1 then. It's the yaw that doesn't seem to work in the start-up. The other two (pitch and roll) do 'the dance'. After the dance the gimball doens't work anymore. Tried blowing air in the articulations and tesing the gimball, but that didn't help. Let's hope replacing the 3-in-1 solves the problem....
 
Good luck, it didn't work for me but I used a 2nd hand cable, I haven't yet tried another cable.

Before you order the new cable disconnect and re connect the 3 in 1 at the gimbal just incase it has been dislodged or something. That assumes the cable is not torn. If it is not torn also have a good look at the cable with either a real magnifying glass or a magnifying app to see if you can see any nicks or broken tracks.
 
A quick search here on the forum for 40002 brings up a lot of threads, some for the mini 2, some for the mini.

Search results for query: 40002

I clicked on one mini thread, and saw this video link, watched it expecting to see a complex tear down, but seemed to clear up with a bit of a jiggle at start up . . .

To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.
 
Hello,

I also have the 40002 error. During startup, the gimbal does not move in yaw-direction.
Where was your ribbon cable loose?

Best regards,
Hendrik
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
132,224
Messages
1,571,110
Members
160,970
Latest member
digitaleconsulting