DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

WiFi Flying Mode Issues - Can't take off after latest Firmware

Frontman

Member
Joined
Jan 15, 2017
Messages
16
Reactions
9
Age
57
So I've been searching the web and forums and there are a few people with my same problem. A day ago I tried WiFi mode for the first time. I could take off, but it kept going into "Auto-Land" mode. Very frustrating. I was trying to use active track but it would not work at all. So, this morning I upgraded to the latest firmware and tried again. Now.....

Mavic is switched to WiFi mode. Perfect WiFi connection (literally 3 feet away from aircraft), perfect image transmission, all satellites good, yet I get a blinking red top message saying "Signal Lost".

I've done a search here and did not find this specific issue, so if it's being addressed I'd appreciate a link to the thread.

So, anyone know the solution?
 
Hi . I have the same problem, I started a thread "wifi lost iOS" and have seen others but no one is able to stead light so far .. :(
 
Also I have noticed that sometimes it alternates between atti and signal lost mode .. and a few mins ago it connected and said ready .. then lost signal .. also the iPhone 6 gets very hot when "connected" .. help !! ..
 
Yes, I too heard the "Atti Mode" a couple times during my trial and error efforts. Definitely something wrong with this scenario.
 
Hope we hear something soon from the forum, I have just emailed dji a few moments ago
 
This is what I can see ..

ce5f8507ebab654386f3baf64448bd5f.jpg


172b17b8f82f7a90940a5e9582cb30c7.jpg


d424efcb361aec0f5c142539768e6d42.jpg
424ab63762ba32eccf812a31574d0818.jpg


ad219703d2b23bc18d60fe0a39b0945b.jpg
493901126eb7b5ab46466cfd7d0f014d.jpg



Thank you for any assistance ..
 
So I'm wondering if I'm doing something wrong ?? .. I just swapped my mavic for a brand new one, registered it, connected WiFi, but it's just same as before :( .. video works but says "signal lost" .. help please .. any ideas ?
 
Also downloaded Go4 to a different iPhone 6, still the same situation.
 
Couple suggestions. your phone screen capture shows you are seeing the Mavic Pro wifi SSID but you are not connecting. Have you entered the PW?

"For security purposes, each Mavic has its own SSID and password that can be found on a sticker on one of the forearms of the aircraft and inside the battery compartment. For your first use, you can scan the QR code with the DJI GO app to connect to the aircraft*, or enter the password manually under your phone’s Wi-Fi settings."

Resetting the PW back to default: "Turn on the Mavic in Wi-Fi mode, press the linking button and hold for 5s."
 
Yes I have entered the password from arm next to the QR code ... iOS can't scan the code apparently ..
 
And hi DonLandis :) .. thx for taking an interest .. .. also if it wasn't actually connected I wouldn't be able to see what the camera sees I guess
 
It's a strange one, emailed dji but dunno if or when they may respond
 
And hi DonLandis :) .. thx for taking an interest .. .. also if it wasn't actually connected I wouldn't be able to see what the camera sees I guess

I don't know about that, but I do know your wifi is not connected according to the screen captures you posted. When properly connected you should not see a ! over the wifi signal icon and you should see a check mark next to the SSID. Later today I might try to reproduce the connection. Hopefully you still have RC control outside with satellite signal.

On my iOS devices, if I wait long enough when the wifi is in that scan mode on the password, I will eventually get a popup asking for a new PW. I would not waste tine with that and just use the reset button on the Mavic Pro. It's in the upper left corner next to the wifi switch and the memory card. To use wifi you must use the reset button the first time. You did that once already, right?

The QR code only works with android accounts, I see after reading the footnote in the manual. FYI- I'm on iOS with an ipad air 2.
 
Thx u, ., so I have just reset (didn't know I could) held button in till the green light went red .. then re entered the password .. still the same .. searching the web re my first pic "no internet connection" in yellow, seems normal .. WiFi only have the "!" After I enter pw. .. also re pics 4 . 5 and 6 above I notice sometimes red and sometimes white Signal icon (2 to the left of the batt status)
 
This looks like a fw issue to me.... The steps you took are the correct ones. The fact that you are getting a video feed means you are connected. It's very strange.
I'll try this when I get home from work tonight to see if I can reproduce the problem.
(i can feel another app update coming!)
 
Hi Adam . Yes I agree with u "strange" .. also seeing same fault on dji forum but no one giving advice .. I have not updated this MP it's brand new is few hours ago .. But the previous MP was running up to date sf and fw
 
then re entered the password ..

That's not what you were supposed to do. The FIRST time you use wifi with a brand new Mavric you are supposed to hit the reset for 5 seconds and thats it! You don't enter a new PW on your iphone because that would be different from what is used in the Maveric. It's the same like connecting to a wifi router. You would need to enter a new PW with a wired connection first for the Mavric, and then enter that same PW on the iphone second.

But something must be screwed up now because if you entered the default PW that is on the sticker on your Mavric, I would think that should work.

You may want to try to delete your memory on the iphone wifi for the Mavric. Go into the wifi settings and tell the iphone to "Forget this Network" the Mavric SSID, Then do a hard reset on the iphone. Now start all over again by setting the switch to wifi and then boot up the Mavric. Once booted, open your iphone settings and now hold the reset button for 5 sec. See if the iphone will sense the Mavric and connect. I had to do that once with another wifi device that just would never recognize the default PW.

Another trouble shooting measure is if you can get another iOS device with wifi and see if that will connect. If that does, then your phone is the problem.

I guess reinstalling firmware might be another option too.

Anyway, I have a few errands to run so I will have a look at mine in wifi later today.
 
I was able to connect via WiFi mode prior to updating to the latest firmware. However, the reason I updated (Goggles being one) is that the behavior the Mavic was displaying was very unstable. The very first attempt, I was able to connect via WiFi, have full video, satellites, etc., and then hit auto takeoff. The thing shot up 30 feet! I was like WTF?? Especially when it says on screen that it will fly to 4 feet and hover. I was able to get the sticks working and lower it, then I tried to do the active track with no success. It just randomly kept going into "auto-land", and I'd have to click the X, hit cancel, and try flying it again, which I was able to, but I kept it very basic, forward, reverse, etc., but after just a few movements, back it went trying to auto-land. So, I thought, Firmware time.

Now, I only get what everyone has read above. Full video, GPS, but the flashing red "Signal Lost" concerning the WiFi. On my two IOS devices I've tried, it shows the Mavic connected with full bars, and I used the password under battery and on the arm with no issues. I noticed the advice of the reset above and see that it did nothing. If anyone else has luck, let us all know. I too will be emailing DJI today.

This all stems from wanting to do Active Track while mountain biking and not having to use the controller. You know, like advertised and shown on so many videos! Grrrrrrr
 
@DonLandis -

I've watched lots of YouTube videos, even the DJI direct that has instructions on connecting via WiFi, and not one of them shows or mentions holding the reset button for 5 sec. Also, that would not explain why I was able to connect and fly before the latest firmware update.

I appreciate your input though.
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
132,191
Messages
1,570,726
Members
160,949
Latest member
Aeronkat