DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Air Encoder Error (0x800020) - Possible Fix

BD0G

Well-Known Member
Joined
Oct 13, 2016
Messages
3,486
Reactions
3,152
Age
58
Location
Near Lake Tahoe NV
Well just received the weirdest Error Message in the DJI GO 4 Application.

I was just out at the park and have had the Mavic Pro Combo for about 24 hours.
Firmware is current. No calibrations done as there is no prompt to do so.

Was ready to fly and powered up. No Image transmission on screen and Little Red Triangle with an Error Message of Air Encoder Error (0x800020).
052759rgstgsp9gvc9cbcg.png


Forward Vision Sensors were also not operable. Gimbal was in disconnected mode as well from recollection. I was about to kick the Mavic Pro down the street and remembered that the only change I made last night (when it was working correctly) was to swap out the DJI Included 16 Gigabyte Micro SD card for a faster larger Micro SD card made by Sandisk. Its the 64 Gig Sandisk Extreme Plus seen here
idse90v3sd64.jpg




So I figured that somehow this Micro SD card was not compatable. I swapped back in the provided 16 Gig Micro SD card and power cycled the Mavic Pro and Controller. BOOM! Resolved!

So this is good as I don't have to send it in for RMA repair after less than a day and bad in that I cannot use my preferred Micro SD card to save larger capacity video and stills. Looks like I am off to shop for a more compatible 64 Gig SD card.

Posted here to potentially save someone the frustration and run around trying to fix thier Mavic Pro.

This is a totally reproducible phenomenon. The moment I swap the San Disk Extreme 64 Gig in the error is presented again.
 
  • Like
Reactions: Teqjax
I use this same card, all I did to make it work was to copied the files from the 16gig original card to this one installed it and it works great!! Didn't even have to format it in the. App either..


Sent from my iPad using MavicPilots
 
Weird! I may have a faulty Micro SD card and that caused the issue although I have read on the DJI forum where there were incompatible micro SD cards that caused this same error.
 
I just wanted to thank you for this post. Apparently this issue isn't exclusive to the Mavic model. I have a phantom 4 that I just received for Christmas and I happened to be using this exact same memory card when I started having issues at the beach this morning. Swapped back to the 16g card that came with it, and it feels like Christmas again. Do you mind if I ask what card you went with?

Thanks again!
 
Hey all - Just got a Mavic Pro Fly More on Friday, was running into the exact same error. Very inconsistent video transmission, video would simply cut out.

Per this thread, I swapped the SD card to a 32GB Sandisk and at first it worked well. However, the same error reappeared during the first flight once the Mavic got around 500 ft away from the RC. Spoke with DJI support and they've asked me to send the drone back. Bummer.

Not sure why the SD card swap didn't work as well on my end.
 
@BD0G, thanks for posting this solution. I've been gnashing my teeth trying to find a fix and dreading an RMA. This fixed that issue, now just got to sort out a gimbal problem...
 
So, I've been messing with this error for several weeks now and, for me, I know what it IS NOT!
1. It is NOT the SD-Card (although it may have been for some people). Reformatting and replacing the SD-Card with a 16gb SanDisk Extreme U3 has NOT fixed my issue.
2. It is NOT the Main Core Board. I have replaced the Main Core board with two (2) known good Core Boards and the issue still remains. Replacing the core board back into another Mavic pro and they work fine thru multiple re-boots.
3. It IS NOT the Video Cable as, Initially (upon 1st boot) the error disappeared until the next re-boot where it promptly returned, so the video cable is working, as are the cables to and from the gimbal control board and the gimbal control board itself.
4. It IS NOT the cable connections to the Core board, as they are all good and, as previously stated, everything worked on the initial boot after replacing the Core Board.

This leaves me to believe it MUST be a firmware issue. But the drone will not complete a Firmware Refresh or a downgrade with DJI Assistant or DUMLdore V3. In both cases, thru multiple attempts, on various levels of firmware and on 2, Known Good, Core Boards, the update/downgrade fails at 36%. So I can't even update/downgrade the firmware. I'm just about ready to throw this drone into the river!
Also, the drone is at 01.04.0500 firmware.

Any help from the community would be DEEPLY APPRIECATED!!

UPDATE: After much angst, consternation and a lot of swearing, I got this PoS working! I replaced the right side cable that runs from the gimbal controller board to the Core Board. Bingo! No more Air Encoder Error! I booted it several times and even flew it around the yard to see if I could get the error to return as it had so many time before! so I put in an SD-Card and BANG, the error has returned! I removed the SD-Card, but the error remained. I reset firmware to factory setting, still the error remained! I tried to downgrade to 0100, crashed at 40%! Tried to downgrade to 400, crashed at 40%! Tried to refresh 500, crashed at 40%! So I have wasted nearly a whole week of my life on this PoS drone. Tomorrow it gets auctioned for parts on eBay!!!
 
Last edited:
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
132,044
Messages
1,568,985
Members
160,827
Latest member
HeidiSue