DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Balky yaw on Mavic 3

TMC

New Member
Joined
Mar 18, 2023
Messages
3
Reactions
0
Age
71
Location
Yelm, Wa.
Have just aquired a Mavic 3. After being aloft for a few minutes the yaw becomes very slow. Landing and re-launching gets it back to normal. Also there is no binocular icon. Only a 7 where the binoculars should be. I have to tap it several times to activate zoom. Appears to be no way to adjust the amount of zoom. It's either on or off. I contacted support and the fellow's enunciation made it impossible to fully grasp what he was saying. What I was able to glean from the tone of his voice was that he had never encountered these issues before. My Mavic 2 Zoom flew away a few weeks ago. I miss it.
 
Last edited:
The M3 takes a bit longer to acquire satellite positioning than the M2 pro/zoom.
Is it possibly you are not waiting for the home point recorded message?
Also, is the M3 a new unit?
The difference between the apps is also a bit of a challenge. Possibly a setting in the Fly app versus the Go4 app?
 
IIRC I think some others have encountered this issue and solved it by deleting and reloading the DJI Fly app.
 
I always wait for satellite acquisition and the "Homepoint has been updated" message. It is a new unit. I'll try reinstalling the app.
 
the yaw becomes very slow
I have seen this on the one I have. A few times. Actually just this morning after a long hover, yaw was very slow. Landed and then re-launched as was fine.
 
Just got the RC controller. Yaw issue is gone.
That’s what I use also. Probably mine is on an older firmware and may be the reason I see the slow yaw on occasion. I’ll search the firmware versions for information before any update.
Glad you got yours solved.
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
129,954
Messages
1,547,850
Members
159,019
Latest member
Mareshal77