Welcome Mavic Pilot!
Jump in and join our free DJI Mavic community today!
Sign up

Crashed Mavic Pro beeping - bricked?

granth965

New Member
Joined
Aug 29, 2018
Messages
3
Likes
1
Age
25
#1
Hello,
I purchased a crashed mavic pro as a bit of a project for days when I couldn't use my working MP.

Tested it on 2 fully charged batteries and I get the same result with both:
Switch on, you can hear it trying to start up, motors do that little twist they do.
It goes quiet right when you would normally get the gimbal doing its thing.
Then it starts beeping, a single beep, 2 second pause, single beep, and so on till I turn it off. The sound is coming from all 4 arms. A search suggests this is the ESCs? If it makes a difference I can notice there is noticeably more vibration in the front right and rear left motors (motors with the white lines). There is also a faint buzzing which appears to be coming from one of the sensors on the bottom, when I put my finger over this it muffles the sound so I'm convinced this is the source.

I've tried pairing it with the remote from my other MP but it won't work (assuming I'm doing it correctly), the controller goes in to "Binding" then times out.

I've tried connecting it to the wifi through my android LG G5 and I can't find the SSID.

Tried connecting to my windows 10 PC and DJI assist 2. The PC recognises the device but suggests there is an issue with it. DJI assist 2 does not change from the "connect a device" home screen - I've had issues connecting my working MP so this does not overly concern me in itself.

Summary of damage:
Gimbal was damaged and slightly bent back on itself. It was sticky going side to side and total frozen in the vertical axis. Knowing this is most likely dead I used a little gentle persuasion and I've freed this off. Still no movement when drone is powered on.
The small tab on one side of the rear arms has snapped off - therefore you can bend the arm slightly past what should be it's maximum travel - I'd imagine this has no impact on the non-starting issues.
The bottom metal case is dented and the plastic casing was popped off at the side.
I've opened it up to check for any obvious physical damage, or loose connectors etc. Whilst the actual fan appeared to be intact, its plastic shroud for bolting it down etc was broke in to several pieces and had damaged the grill.
Everything else appears to be intact and to the untrained eye in usable condition.
What I did notice it that it looks like someone else had opened it up - there was a single screw missing in the battery tray.

Current thoughts:
Previous owner has crashed it and bricked it.
Previous owner has crashed it, opened it up to repair/replace the fan and/or gimbal and touched something they shouldn't have.
Is the damaged gimbal is preventing the device starting up.
Is the damaged fan preventing the device starting up.
Has the fan stopped, causing the device to overheat and that's why it crashed.
Is the potentially faulty sensor causing an issue.

After some more searching this evening I realised that it has an internal SD card containing the software (assuming it is an older build), I did notice there was a finger print on the cover of this (could well be my own), so tomorrows plan is to remove this SD card and inspect it.

Thinking the worst and that it is totally bricked.
Any and all help is appreciated.

Regards,

Grant
 

granth965

New Member
Joined
Aug 29, 2018
Messages
3
Likes
1
Age
25
#2
Bugger, realised I've posted this in the Mavic Air section. Would an admin be good enough to move this for me?
 

rickw

Well-Known Member
Joined
Aug 23, 2017
Messages
511
Likes
214
Age
68
Location
Delaware
#3
sounds like it it needs to be sent to someone for repair,you have too many issues
 

Cyberpower678

Well-Known Member
Joined
Jan 11, 2017
Messages
3,943
Likes
1,743
#4
sounds like it it needs to be sent to someone for repair,you have too many issues
Either the FC is bad for some reason, or the FW is corrupt. If you can remove the SD card, there's a post somewhere where someone said that they pulled the SD card out and formatted it and re-installed the FW manually.
 
Joined
Oct 16, 2018
Messages
9
Likes
0
Age
31
#5
Any news on this problem? I have the same problem where the 2 fornt motors are beeping and the RC wont connect to the MP. Thinking about flashing the firmware with dumldore to see if this helps.
 

ac0j

Well-Known Member
Joined
Sep 17, 2017
Messages
2,353
Likes
1,801
Age
55
#6
The one thing all these resurrected “beeping” threads have in common is a crash.
If you crashed it and tried to fix it. You probably muffed the repair. These are pretty complex. Send it to @Thunderdrones and let him sort it out. If it is not the tiny switch in the as card area out of place.
 
Joined
Oct 16, 2018
Messages
9
Likes
0
Age
31
#7
I read a lot of threads about this issue.
My mavic crashed, after letting it dry it could connect but i was getting esc errors. Then when i tried to update, the update failed and after that i could not connect to the controller. it would connect to the go app and assistent but i could not calibrate anything, every update failed (even in dumldore) and the 2 front motors were constanly beeping.
I bought a used main board, since i thought it was bricked, but after installing the new/used main board i got the same problems; the problem was not in the main board.
Since i got the esc errors in the first place i was planning on replacing the esc board anyway. Then i read this thread: "Mavic Pro (the craft itself) wont stop beeping". in reacting #4 someone stated that after a crash the flight controller can detach from the esc pbc. so as a last resort i ordered a esc board here, and found someone with proper soldering skills to mount it. after soldering it i turned it on, all 4 motors responded and it booted up normally! it only tells me i have no gps and need to calibrate the compass. i noticed one of the wires to the rear gps board is loose so i have to fix this. but besides that no other issues, gimball en imu calibration are going smooth.
due to the compass/gps i have not been able to fly it yet, but i thought i'd share my story. maybe it helps someone, since every thread about this i read did not come with a solution or people ended up sending the mavic to dji and getting refurbished mavics back.
 

New Threads

Forum statistics

Threads
48,881
Messages
571,238
Members
72,329
Latest member
butchs38