DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

DaVinci Resolve optimized media with DNG hyperlapse


Well-Known Member
May 16, 2020
Mineral Point, Pennsylvania
I'm creating 4K hyperlapses using the 4000x3000 DNG image files from the Mavic Air 2. I create a UHD project, and set the input scaling to center crop with no resizing:



Now I can bring in the directory full of DNGs, and they just fill the video from left-to-right. Because of the 4:3 aspect ratio, they overflow the timeline vertically, and I can use Position Y to adjust the framing. The rendered video looks good. This is all exactly what I want:


However, because it's a pile of DNGs, it's laggy to work with during editing, so I want optimized media. Whenever I run "Generate Optimized Media" on the DNGs, the resulting optimized media appears smaller. Even the 3000-pixel vertical dimension has been shrunk smaller than the timeline, so there's a black window around all four sides:


If I use "Zoom" to "fix" this issue, everything looks good until I render, and it goes back to the original files and is zoomed in too much. Is there some setting I'm missing to get the optimized media to match the size/aspect/zoom of the original DNGs? I've tried various settings of Optimized Media Resolution and Optimized Media Format without effect. Thanks!

Hi coneslayer, I also use Resolve to process 4K hyperlapses. However after I post process the raw images into a new folder, I just select that folder in the Media tab in Resolve and drag it to the bottom pane. In the Edit tab I just drag that selected folder into the timeline and it shows up as a single video. From there I "Generate Optimized Media" which goes pretty fast. Then I just use Stabilizer and then Render. It never appears smaller after I Generate Optimized Media. Its actually much faster than processing videos as the color correction has already been done. Not sure if this helps you but that is my procedure.
However after I post process the raw images into a new folder

Thanks for your reply. When you say "after I post process the raw images", I take that to mean you're using Photoshop or Lightroom or something to process the DNGs and export JPEG, TIFF, etc.? I'm trying to avoid doing that, as Resolve seems to do a nice job with the DNGs on its own, and I'd rather not have to jump between programs. Everything works to my liking in Resolve so far, except for the Generate Optimized Media issue, which looks like either a bug or a misconfiguration that I can't figure out.

If my understanding above is correct, are you exporting the full frame from the image editor, or are you exporting your final 16:9 (or whatever) crop? I wonder if the 4:3 ratio is contributing to my problem, but I want those pixels to be available in Resolve for stabilization and dynamic up/down pans.

I'm sure I could also work around my problem by immediately rendering the DNGs to a video format in Resolve, but, again, I'd rather things just work right without the extra step, and again I want the out-of-frame pixels to be available.

I just select that folder in the Media tab in Resolve and drag it to the bottom pane. In the Edit tab I just drag that selected folder into the timeline and it shows up as a single video.

Just for clarity, a folder of DNGs works the same way, and that's what I'm doing.
Last edited:
I process the DNGs using DxO PhotoLab3 and export the JPEGs. I do export the full frame. I do believe I have used both 16:9 and 4:3 ratios. I'll test 4:3 tomorrow to be sure. I do understand not wanting to take the extra step. I will try it your way and see what happens and post my results.
  • Like
Reactions: coneslayer
coneslayer, I pulled a hyperlapse from yesterday and set the RAW folder in Resolve. I archive the "good" hyperlapses so I have a copy of the RAWs. I always set my timeline for UHD.


I left the input scaling at its defaults.


When I brought the folder to the timeline, it displayed as 1 video file. I did not experience the vertical overflow. After I ran Optimized Media, the size did not change.


This is after I optimized. I ran Stabilizer, then Render, and the video came out pretty good. I did not do any color correcting as this was a test.


I'm wondering if it is the 4:3 ratio. Let me know if this helps or if you want me to try this with your exact settings. Don't laugh at my oversized sky scene, I thought I was going to get some storm lapses (epic fail). I do like the scene you chose as the reflections in the water highlight the video
It's not the 4:3 ratio. Mine drone is set at that. However when I pull the RAW images folder to the timeline, my images are aligned horizontally.


Just an FYI. I'll experiment some more today.
It's not the 4:3 ratio. Mine drone is set at that.

Thanks so much for helping with this. I'm happy to say that the issue is resolved on my computer, but I'm not sure exactly how. Some fun things arrived in the mail, so I:

- Upgraded system RAM from 32 GB to 64 GB
- Upgraded from free Resolve to Resolve Studio
- Switched from GeForce to Studio NVIDIA drivers (based on some other troubleshooting advice)

One or more of these seems to have fixed the problem, and I'm not sure which. When you upgrade to Studio you install a different build of Resolve, so maybe I had a bad build of the free version, or something corrupted with my installation of it.

Anyway here's the final result; thanks again for helping me get there.

I have the same issue with my Mavic Air 2 Hyperlapses.

When I use the image sequence in the original 4000x3000 pixel size the image is very small after using "Generate Optimized Media".
How much the image shrinks after optimizing seems to depend on the size of the source images. Only if I resize the images in Lightroom to 3840x2160 it stays the same after optimizing in Resolve. I am using the free version of Resolve.

Source Image Sequence 4000x3000 (4:3):

Source Image Sequence 4096x2304 (16:9):

Source Image Sequence 3840x2160 (16:9):
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Members online

Forum statistics

Latest member