Welcome Mavic Pilot!
Jump in and join our free DJI Mavic community today!
Sign up

Gimbal going crazy at startup, DIY flatcable replaced...yes!

MBL

New Member
Joined
Jul 4, 2018
Messages
3
Reaction score
0
Age
50
My MP, production sept '17 showed gimbal issue's after 20 flights....great!
This gimbal thing has been an issue since the beginning of the MP almost 2 years ago!
No change in design done since.

A known issue, gimbal goes crazy at startup, bangs its lens to the chassis resulting in gimbal alarm overheat and possible obstruction warning. Holding the MP to one side durig startup worked for a couple of days, later it didn't anymore.
Gimbal is not obstructed nor warm, never crashed.
Had to make the decission to ship or not to ship back for repair, after reading all issue's with getting back an referb MP for an almost new one....nope, I will not ship.
It's time to roll up the sleeves and DIMyself.
8 Euro's for a flat cable, 2 weeks shipping..time enough to watch HowTo's on YT.

Make sure you have a proper magnifying glass and tools, it can be done.

So happy with the result, especially after a DIY job, to see it all working again...feels great!
My replacement flat-cable also looks to be stronger then the original cable.

I'm a happy flyer again!
 

Former Member

Well-Known Member
Joined
Dec 20, 2016
Messages
14,022
Reaction score
13,026
Location
Duluth, Georgia
Glad you got it fixed. It's not an easy repair by any means, but anyone who has micro device repair experience can probably tackle it.
 

New Threads

Forum statistics

Threads
71,904
Messages
833,439
Members
98,951
Latest member
François D.