DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

HELP! With goggles......... PROBLEM FOUND


Well-Known Member
Premium Pilot
Mar 8, 2017
Bring up DJI assist 2. Drone, controller, and racing goggles are on. Hooked to computer, goggles. Nothing happens. Assist just sets there. App, is 4.3.0. What am I doing wrong? Thanks for any help. Driving me crazy.
Last edited:
When I updated my goggles I DID NOT have the MP on or the controller. DJI Assistant 2 had no problem updating. Highly recommend updating everything separately via Assistant 2

Of course I would reboot the pc
If you read about a guy limping down the street, screaming my goggles want undate, it's me. Tried what you said. Tried two different computers.

More info: When the goggles are plugged in all of the computers, we get this message:" USB device not recognized.The last USB device you connected to this computer malfuncted, and Windows does not recognize it.."
  • Like
Reactions: Johnnyaibo
Updated all drivers, and Windows. Same thing. Am i missing some thing? Could it be the goggles?
Thank you for the info. I learned some thing new. Didn't work. Not working on three machines, or with other DJI devices. Different cables.
Took my mavic v1, that the goggles work on, to see if it would update them to the current version. It did an update to the aircraft, but not the goggles.
Anyone having the same problem?

Anyone know where to find the version in the googles, and what is the current version?
I had to run the update as administrator. No problems after that.
It took my wife's help. I am old teck, and she is new teck. I was a main frame operator, and Cobol programmer.
  • Like
Reactions: Speedmeister
I found out my problem also. I had all the current software loaded but thought that I had Mavic Pro...I have a Mavic 2 Pro. After I entered a Mavic 2, the goggles and drone linked fine. All is fine.

DJI Drone Deals

New Threads

Members online

Forum statistics

Latest member