Get more from your Mavic
The largest Mavic community in the world
Join Us Now

mavic air battery signal error.tried everthing

reaper_j

New Member
Joined
Apr 10, 2020
Messages
1
Reaction score
0
Age
36
Location
newzealand
RIghty o ive never poster on here so if im going about it the wrong way then sorry, im new to the site but not the product.



Problem? M>A showing battery signal error .


Was unit in a crash? no

What have you tried so far?: switch battery out yep,not the issue , tried to refresh firmware but cant as battery showing as under 50 percent but its not ,i can get it to fly but only by using assistant in debug mode and marking the battery as a non dji{dumb} battery but then the problem of no smart features and it wont read a voltage so registers as under 50% and wont allow any update .im trying to get it to a point where it will update the section of firmware that controls battery functions but no go even switching between older assistant in debug(so as to select non intellegent battery option ) then uninstalling and running newer versoion of assistant and refreshing , no good ,i can get to 99 % using external progs and flashing firmwares on dumldore but thats it. so yea i can fly it but its dangerous and holds back a few features ,once again ive swapped batterys ,opened it up and cleaned and checked for dry soldier around chips relating to sensors in reguards to battery,ive tried other phones and another r,c.


What device are you using? android

What firmware are you running ( aircraft, remote controller)? dreaded .620

What Go app version are you using? newest version and older and pilot litchi

Any modification? yolza

Did you change anything or install any apps? not on this one

Do you have a video or pictures of the problem? ...

.