Get more from your Mavic
The largest Mavic community in the world
Join Us Now

Mavic Air: RC signal lost for 5 seconds while at 10ft from me

ManuCH

Well-Known Member
Joined
Dec 3, 2017
Messages
65
Reactions
27
Location
Zürich, Switzerland
Hi guys,
so I have been flying a Mavic Pro for a while and I've always liked it. Zero issues. Yesterday I added a Mavic Air to the collection and I've been out flying it today (of course after upgrading all the software). I'm using DJI Go 4.2.21 on iOS 11.4 on an iPhone 8 Plus.

Unfortunately, during my 3rd flight something strange happened: while it was literally at 10ft from me, after completing an Asteroid QuickShot, DJI Go 4 showed "RC Signal Lost" followed by a black screen and "No image transmission signal".

The Mavic Air went into auto RTH mode (just as I had instructed it to do). As it was very close to the home point, it wanted to land immediately.

5 seconds later, the signal and image came back, so I was able to abort the landing and continued the flight without any issues.

Has anyone else experienced such random signal losses while nearby? I was able to fly the quad 1500' away just minuted earlier with 0 interference (I was in a mountain area with no interference). Could I have a lemon? Anything I can try?

This is the AirData link: 19-06-2018 13:02:02 | General / Overview | Drone Flight Log from DJI GO app, version 4.2.21 on iOS | Total Mileage: 3,653 ft | Switzerland | Airdata UAV
I will upload the log and a video of what happened when I'm back home.

By the way, I had cellular data (4G) active while flying, as well as Wifi (although not connected to any network). However, I didn't think this might be an issue, as it didn't matter while I was flying much further away. Has anyone *actually* encountered issues with those active?

Thanks!
 

wildlifr

Active Member
Joined
May 15, 2018
Messages
44
Reactions
18
Age
49
Yes, several times. It's clear that these situation have nothing to do with signal strength, and so I attribute it to either the app, or the phone itself. I will usually immediately reboot the controller and the restart the app when this happens, which solves the issue. I've been trying to get into the habit of restarting the phone prior to flying. The 4G/Wifi could also be part of the problem. I noticed that in areas of limited 4G signal, where the phone is struggling with 4G strength, I've had bad interference issues that immediately went away when put in airplane mode.
 
  • Like
Reactions: ManuCH

ManuCH

Well-Known Member
Joined
Dec 3, 2017
Messages
65
Reactions
27
Location
Zürich, Switzerland
Yes, several times. It's clear that these situation have nothing to do with signal strength, and so I attribute it to either the app, or the phone itself. I will usually immediately reboot the controller and the restart the app when this happens, which solves the issue. I've been trying to get into the habit of restarting the phone prior to flying. The 4G/Wifi could also be part of the problem. I noticed that in areas of limited 4G signal, where the phone is struggling with 4G strength, I've had bad interference issues that immediately went away when put in airplane mode.

Have you also have a situation similar to mine, where the signal came back by itself after 5 seconds, without needing to reboot the controller?
 

wildlifr

Active Member
Joined
May 15, 2018
Messages
44
Reactions
18
Age
49
Have you also have a situation similar to mine, where the signal came back by itself after 5 seconds, without needing to reboot the controller?
I don't think so. But then again, I usually don't wait long before rebooting once I recognize that it's not a signal strength issue. Yours might be more of a case of 4G interference. My feeling is that there's more likelihood of interference when the phone is trying to download data (like the map in the dji go app) than when the phone is basically idle. But I haven't tested it properly. I generally let the app download the local map data, then go into airplane mode.
 

IM35461

Member
Joined
Jun 8, 2018
Messages
5
Reactions
1
Age
64
My one did this twice after fitting third party carbon fibre props.

Went back to the old ones and all was well again (except for the drifting issue which seems to effect main MA's).
 
  • Like
Reactions: ManuCH

Letac

Active Member
Joined
Feb 26, 2018
Messages
39
Reactions
16
Age
45
A week ago I lost reception numerous times while the MA was less than 20 feet away (over the river!). There was no warning about signal interference, it just went grayscale, but luckily each time the signal came back.
 
  • Like
Reactions: ManuCH