DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

Mavic Pro don't read SD Card

ClassyKMR

New Member
Joined
Jul 27, 2021
Messages
3
Reactions
0
Age
29
Location
Poland
Hi everyone, it's my first thread here :)
I've got my drone for 3 years and unfortunately i came with a problem i cannot resolve myself i hope someone can help me. I see this errors for the first time.

Problem?
My drone don't read any SD Cards, on controller i get notification "SD CARD ERR CHECK APP", also in DJI app i got notification "Unknown internal storage error"

Was unit in a crash?
No

What have you tried so far?

I tried to format my both SD cards (SanDisk Extreme 16gb, Samsung EVO 64gb) inside DJI app but i got message "SD card formatting failed". Then i tried formatting both cards via PC both in FAT32, exFAT, NTFS format. I also via DJI assistant again installed latest update. I want to mention that both cards worked perfectly so far and i didnt fly very often so they are for sure not dead.

What device are you using ( iphone , ipad, Samsung , etc)? Oneplus Nord N10

What firmware are you running ( aircraft, remote controller)? V01.04.0500,

What Go app version are you using? 4.3.37

Any modification?
No

Did you change anything or install any apps? No

Do you have a video or pictures of the problem? (if so post link)

I hope someone will help me thank you!
 
Surprised that both SanDisk and Samsung cards failed to work, as they are 2 of the best in the market. If it isn't a hardware problem with the drone, you can try the SD association's official formatter @ SD Association, download it from the site. It's what we use b4 sending out any electronics with an included SD card. There are 2 options, quick format and overwrite, which can take some time depending on the card capacity. Formatting with a PC is ok, but using the SD Association's formatter usually solves a non hardware problem.

Best of luck, Cheers!
 
Thank you for your reply!
Unfortunately your solution didn't work either so i decided i will take my bird for service. I hope it's not fired motherboard, thanks again!
 
Did you find a fix? I have the same exact problem. I assume it's an SD slot MB issue and it will need to be replaced. I'm just curious if you got it working and what was the actual fix.
 
I don't know yet because I forgot to take it to the drone service for repair :) After I have some new information I will tell what was the problem :)
 
Was it the SD slot or the Mother Board? Did ClassyKMR Find a solution? I'm having the same issue
I took it to a local shop. The charge to replace the board was to expensive for me to repair. I've looked at purchasing a board online but haven't pulled the trigger. My drone is 4 years old and really don't want to drop half of the cost of a new one to repair it.
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Members online

Forum statistics

Threads
132,714
Messages
1,576,265
Members
161,424
Latest member
George2505