Welcome Mavic Pilot!
Jump in and join our free DJI Mavic community today!
Sign up

Mavic Video Image Jump Issue (still)

GrizzlyAK

Active Member
Joined
May 14, 2018
Messages
27
Reaction score
7
Age
57
My Mavic Platinum Pro video jumps at the end of a gimbal tilt (up or down) while also yawing, every time. You can see (and hear) the drone hesitate in its yaw action when this happens. Thought this was a gimbal issue, and had drone replaced with a new one. Same issue with brand new drone, but more experimentation showed that the drone actually hesitates during its yaw when gimbal tilt action ends on RC. Does not seem to be a faulty gimbal after all. You can replicate this at 4 feet altitude (and see/hear it) as shown in the following video (Password is mavicpro).

Private video on Vimeo

Can anyone else replicate this? This issue ruined a lot of my footage on a recent trip to Iceland, and even after receiving a brand new drone replacement, the issue still exists. I can't be this unlucky. It basically makes the Mavic Pro useless for serious cinematography (unless you don't need to yaw and tilt at the same time ).

My aircraft firmware is v01.04.0300 (with RC, batts, and Go4app at consistent level).
 

GrizzlyAK

Active Member
Joined
May 14, 2018
Messages
27
Reaction score
7
Age
57
OK, so I've created another video of the drone in flight to illustrate the issue described above. In the video you can clearly see and HEAR the drone hesitate its YAW motion whenever the gimbal tilt control is returned to neutral. I show the drone in several configurations, as well as the actions being taken on the RC to make this happen. Basically, as described, I am only yawing in either direction, and tilting the gimbal up or down, and whenever I return the gimbal tilt control to neutral WHILE yawing, the drone hesitates it yaw motion. THIS is causing a jump in the image on any video taken under such control circumstances.

Again, the password is mavicpro. The video is here:

Private video on Vimeo
 

GrizzlyAK

Active Member
Joined
May 14, 2018
Messages
27
Reaction score
7
Age
57
Can anybody report whether or not they experience this issue with their MPP? This appears to be a SW/FW issue, which would affect everyone, but I've not heard of it, except on the two drones I've had. Thanks!
 

New Threads

Forum statistics

Threads
71,757
Messages
831,641
Members
98,806
Latest member
edleidel