DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

New M2P Controller will not connect to Windows 10 PC (USB driver issue?)


Aug 27, 2018
New England
I received a new M2P yesterday. I had preinstalled DJI Assistant 2.0.0 (Windows 10 i7 laptop with all current updates)and used it to update the aircraft with no issue.
(I should note here that this is my second DJI M2P - The first one was received damaged and I returned it for a full refund. This is why I had the Assistant installed)
I disconnected the aircraft and connected to controller to update it. Upon connecting the USB cable to the computer (Controller ON) a windows note popped up stating device software was installing then a windows stating that the DJI device was installed and ready.
The Assistant program showed an icon for the controller and I clicked on it and started the update process. The process went to Installing 72% (It completed the prior processes, download etc.) and stopped. A Windows window popped up stating the USB device was disconnected. I was never able to connect the controller to the computer (via Assistant ver. 2.0.0) again. I waited 25 mins just in case before closing the program. I tried several reboots and reconnections.
In windows device manager in Universal Serial Bus controllers I get a line with the error "Unknown USB Device (Device Descriptor Request Failed) when connecting the controller. (Same with three different micro USB data cables.) Also tried removing the USB device driver in Device Manager. It removes the Unknow error line and I assume the driver but get the same results when rebooting and trying again.

I called DJI and was told to use the GO4 program to update the controller (Hold three line icon for 10 seconds to bring up update menu) This worked and I was able to update the controller and make my first flight with this nice drone.

After the controller update I tried connecting to the computer again with the same USB issue listed above.
I then found that the DJI Assistant was updated to 2.0.2. I downloaded it, did a uninstall for the DJI assistant ver 2.0.0 and rebooted the computer prior to installing version 2.0.2.... (No USB Device software install windows popped up at the end of the install - See info later concerning this on another computer)
The controller is now no longer recognized at all by this laptop. I no longer see the USB "Unknown" error in Device Manager. There is no computer reaction at all when the USB cable it plunged in to the computer with the Controller connected and ON.

I then installed DJI Assistant 2.0.2 on another computer ( i7 Desktop Windows 10 with all current updates). At the end of the installed I had a permission window pop up asking to install USB drivers for this device (had some Chinese character letting in the description). After this installation was complete I connected the controller (ON) and it was recognized by the computer and the DJI Assistant 2.0.2 program without issue.

So the problem seems to be some USB driver issue that occurred during the installed of the update of the controller while using the update. (At 72%)
I should note that during all of this I did not move the controller or any of the cabling so there should not have been any electrical connection issues present to cause this.

Sorry for prattling on so but wanted to give all the info I have. My question is how do I remove, repair, replace, whatever …. the USB driver to get this controller to be seen by this laptop in the future? I did a search in "Regedit" on the laptop with this issue and found a DJI referenced USB device in:
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Portable Devices\Devices\………...
and am thinking about deleting this (after backing up the Reg files) but know the risks. This will be a possible last resort.
What I would like to know is a way to force the reinstall of the correct USB driver for the controller communications.
SO, hoping someone can help me get this working on my laptop.
Other Mavic controllers need to have the cable connected while OFF then powered up.

Another possibility is the Mavic Air controller in addition fails to connect to some computers because it tries to charge with too high a current and causes connect/disconnect loops with them.

Could be one of those or something else. But you don't actually need to connect it to a PC for anything but updating which you could do with the mobile device, so it may not matter much.
First, thanks for your quick reply. At first read I though " this can't be it as I did that". During the troubleshooting this issue I tried every variation I could think of with the same results.
But after 50 years working in various sectors of the electronics industry I have learned, sometimes painfully, to never disregard advice on a problem without first trying it out. So, I set up the program and followed your advice. And it work with out issue. I did a Refresh Update to make sure and it completed great. So thanks again.
But I then tried all the other variations and they worked also. Not sure what is going on but today I have several times uninstalled, rebooted, and reinstalled Assistant 2.0.2. Maybe something finally cleared the issue.
In any case, I thank you for your help and consider this closed. Going to go flying.. :)
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Latest member