DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

No SD Card detected


New Member
Jan 28, 2017
Hi everyone,

I've tried everything I could find about this, but no luck.
So here is what is wrong:
- camera is blurred and message "No SD Card detected" is showing

And here what I tried:
- all kinds of connect/disconnect/take out/put in stuff you can imagine;
- two different sd cards which are fine and worked
- formating in various ways from my pc(format from the aircraft is not possible, because the card is not detected)

And this happens occasionaly and when I try a few times to update or refresh the firmware, at one point it works again. And after some time when I decide to record again and maybe use another phone or something, then this problem is again present.

Any help appreciated.
  • Like
Reactions: Xbastien
We had almost exactly the same experience and it took a bit of digging but I did find the answer.
SD cards that are 32gb and under should be formatted as FAT32, SD cards 35gb and over should be formatted as exFat.
Do it from your computer as the Mavic will format it as FAT32.
Hope this helps!

Thanks for the answer, but this does not help. If the sd card is formatted wrong, the drone shows it and you can format it from the drone. In this case the drone just says that there is no sd card inserted. Also I already tried every existing way of formatting to overcome this.
When I do firmware upgrade for example and it recognizes it and I format it from the drone. Then I can use it and shoot. And then when I turn it off and on and try again, it again says no sd card. Sometimes if I turn off and on the drone or the remote, or press the shoot button, the sdcard starts working. Totally random principle......
This is really frustrating.... So much money for this drone and it does all kinds of random crap.

Away from this topic DJI even pushed an update which damaged my battery and it is completely dead. I had to buy another battery back then.
The Mavic (as far as I can tell) only formats as FAT32 so if you’ve formatted a 64gb card in it will be in the wrong format. Doesn’t make a lot of sense to me considering most , if not all DJI drones will take larger SD cards.
I’m not sure what to say about the random issue except at least some of that might be caused by formatting in the Mavic. We have had a few random blurry image problems as well and have solved some by using the manual focus slider on the screen

Have you tried using different types of SD cards as well as different sizes?
I use 16GB which comes with the drone also another 16GB Sandisk extreme U3.
I even tried a 128GB Samsung just for the sake of trying everything and I can report the same. ->
I get an error "No SD card detected" (please note that this points that the problem is not in the formatting of the card, because if you insert a wrong formatted card you can format it on the drone and use it). I get a notification that new firmware is found and when I update, then I can use my drone again. I shoot and film. Then when I recharge and go again, I have to go through the same circle.
No SD card error->firmware upgrade detected->......
You are absolutely right about the 16gb card as it should be formatted FAT32, the 128 however needs exFat and the Mavic formats as FAT32.
We had the exact same issue with the blurry image and the firmware update and have solved it (so far at least) with a new SD card. I’m going to be very interested to see what happens in the near future . We have only been out once since this issue and had no problems.
Sorry I couldn’t be of more help, I know how frustrating these issues can be.
Exactly the same problem here. Been trying to get it to work for about year now. Redo the firmware to old then update, works fine first flight stops seeing the card next flight.
Any one find out what the issue is? Not sd card as i have tried without any sd card and switched aircraft to wifi mode rather than rc and got camera feed for a few minutes and it then stopped. Almost like the gimbal goes offline. What gets me with firmware upgrades and downgrades i was able to fly and record in the past now firmware downgrade or upgrade fails at 44% most likely because gimbal is not detected. However screen calibration with cameras works perfect every time
My Mavic Pro has now also developed this problem. I've tried formatting via SLR and PC, different sd cards (although I can't find the original one), firmware refresh via DJI Assistant 2 (mine also initially failed at 44% but reached 100% after a few attempts), restore factory settings etc. but all to no avail. Any offers of help / solutions or somewhere near North Essex who I can trust to fix it would be much appreciated. Thanks, Tim


  • Mavic no sd card screenshot.jpg
    Mavic no sd card screenshot.jpg
    218.7 KB · Views: 25
I don't think I'd spend that much on an MPP these days. Apply the money on an upgrade. Just my opinion though.
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Latest member