DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

This is how I fixed the "Quick Transfer Password Authentication Error" on my DJI Mini 2.

LoudThunder

Part 107 Licensed
Joined
Oct 1, 2021
Messages
2,631
Reactions
8,595
Age
73
Location
York County, VA. USA
I am posting this under General Discussions since this problem is not limited to the Mini 2.

I recently had to replace a Mini 2 Drone with a replacement Mini 2. The New Drone worked perfectly; then I tried to perform a Quick Transfer of the files from Drone to my Tablet. Each time I tried to perform this function; I received a "Password Authentication Error."

If you are reading this, you probably are having this problem also, so I will get directly to the point. If you own more than one DJI Drone, then only look for the model that you are having problems with (ie: Mavic 2, Mavic 3, Mini 2, etc…). If you have more than one of the same model, then that might be why you are having this problem. The Drone sees the first Network ID, but finds a different MAC Address. With this issue I cannot help you… I suggest you buy two phones then, one for each Drone…

This posting is written in two parts. First Part, just the information you need to fix the problem. The Second Part (at the end of this posting contains all the "whys and wherefores," you can read the back-story on how this all came about…

To start off, I am using a Samsung Galaxy S2 Tablet so any Android Tablet or Phone should operate much the same way. Apple Tablets and Phones will probably have similar screens and entries, but you are on your own and if you figure out how to do it differently, I hope you also take the time to post the instructions.

So, Let's get to work! Like Sergeant Friday says, "Just the facts…" First off, you need to clean out any reference to your DJI Drone's Network connection from past attempts to perform a Quick Transfer.

Open the Pull-Down-Menu of the Android Quick Settings Menu (Just drag your finger from the top of your screen downward). CLICK the Network that you are on. Do not CLICK the Icon (that will turn off the WiFi).

1.png

Now CLICK "Details"

2.png

Now CLICK "Advanced"

3.png

Now CLICK "Manage Networks"



4.png

On the Right Side of the screen, you will now see all the WiFi networks that you have ever logged onto. Your Screen will look much different from mine. Your active networks will show up at the top of the list. The Network that you are presently logged onto will appear in BLUE.

5.png

SCROLL through the list, it's alphabetical (numbers first, then A thru Z…), you are looking for the "DJI-your-drone-XXXXXX"

6.png

On this Screen, you can see that I have three entries for my "DJI-MINI2-XXXXX. The first entry is for the Mini 2 that I returned and the second and third are for my New Mini 2.

7.png

Click on the first DJI Network Entry and CLICK "Forget" (That entry will disappear from the list) and do this for each and every "DJI" entry. You are "cleaning" out (actually Deleting the entry…) all the previous attempts to link your Drone to your Tablet/Phone, to start fresh.

Now you need to create a new link for your Drone to link to perform a Quick Transfer. The following YouTube Video is pretty straightforward. "How to get DJI mini 2 WiFi password | quick transfer"


But I am telling you this now! When he tells you to do something, PAUSE the video until you have done it, then CONTINUE the video. For example, he will tell you to turn on the Drone and wait until it completes its Self-test, but he doesn't wait, he keeps talking and you might miss an important step while your drone is self-testing…

I did this and my drone immediately performed the Quick Transfer perfectly…

One final point, if you do this at home, your home router might "bully" past the Drone's network and if this happens, you will need to disable the Tablet's/Phone's WiFi and manually turn it back on when your Drone is flashing it Blue Quick Transfer tail light and manually select the drone's Network.

Now, if you want to know all the "Why's and Wherefores," then keep reading and you will get the full The Back Story…

back.jpg

I bought my Mini 2 from Costco earlier this month. It flew great and it took me a while to learn the intricacies of the Editor. It was then then that I discovered that the camera had issues and all my videos had a GREEN Bar on the bottom of the video and several GREEN Lines streaks also.

I had also purchased the DJI Care Refresh Service Plan; but I do not want to use one of my repairs on a Drone that was clearly defective to begin with so I returned the Drone to Costco and purchased a New one.

The following posting is my Story of returning the Drone to Costco and Transferring the DJI Refresh Policy…

Anyone change the Care Refresh Policy from one Drone to a Replacement/Exchanged Drone?

Setting up the new Mini 2 was a snap and after testing the Drone out (flying, photographing, and videotaping) I brought the Drone in to perform a Quick Transfer of all the files to my Samsung Galaxy S2 Tablet (Android…); but I kept getting a "Password Authentication Error".

A quick Google of the error suggested that I needed to enter "12341234" in as the password--it did not work…

Another Google search came up with the suggestion to use the Drone's Serial Number--it did not work either… And that explains why I had two WiFi entries for my new Drone…

I then started a Deep Search of this error and found numerous other folks who also had this issue and it was not isolated to just the Mini 2 and the inquiries dated back a couple of years. However, in none of these searches did I find a solution, just suggestions…

I found the aforementioned YouTube Video and performed the procedures many times without benefit (but I did not give up hope yet…). The first issue I had that I kept having while putting the Drone into Quick Transfer Mode was that my tablet kept finding my home's WiFi before it found the Drone's WiFi. It was when I shut down the "Auto Connect" of my home WiFi that I noticed the multiple entries for the Mini 2's Network Connection and I knew that was not right, but I could not quite put my finger on it…

After I shut down the "Auto Connect" on the Home WiFi, the Drones and Tablet immediately linked, but now I started receiving the "Password Authentication Error"

Some more research and I discovered that DJI uses WPA WPA2 PSK encryption to provide a "shared encryption key" to protect network access and data transmission. DJI does not deem a password necessary since the WiFi signal is limited to 1-meter and the Drone is bound to your DJI App.

When your Phone/Tablet tries to make a connection, it goes through the Linked List and when it finds a match, it tries to link up, but because the New Drone's MAC Address was different it could not connect. Then I tried it again, but with a password, and then I tried it again with a different password.

Your Tablet/Phone does not know this and will let you put in a password, but the Drone is not expecting a password so it "says, Uh-uh, nope, no-way…", so DO NOT Enter a password…

So, in conclusion, you need to delete every "bogus, mis-matched, old, retired, passworded, etc…" entry that refers to your Drone in the Network Listing.

After you have deleted all these old entries, when you again attempt a Quick transfer, your Tablet/Phone will generate a new Network Connection for your Drone and that will that will eliminate the Password Authentication Error…

Actually, you could delete every entry in the Network Connection list and when you once again have access to that network, your phone or tablet will ask you if you want to access the WiFi. But if the Network was password protected, you will have to enter it then to regain access (the list saves the passwords for you) and if you forgot the password, you will not get access. So, I am NOT advising you to delete any other entries on the list other than the DJI listings.

Now, all I need to do is get past the 4K Transcoding Error. Actually, it's probably that my Tablet is not powerful enough to process all that video. I downloaded the 4K video right off the MicroSD card onto my desktop computer and when I played the 4K JPG files, my computer "screamed for help… The video stuttered and was choppy and it was not the video. I played the sequence over several times and the problem areas kept showing up in different places, one time this scene was fine next time it stuttered… So, if my computer has problem just showing it, I cannot imagine what my little Tablet is going through trying to process that video. At the end of the day, I'm very happy with my Mini 2 and if I cannot fly it in the rain, snow, or in 50-MPH wind, and just have 2.7K video, well that's OK with me…
 
  • Like
Reactions: Grandpa
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
129,930
Messages
1,547,582
Members
158,989
Latest member
zecadronerescue