Welcome Mavic Pilot!
Jump in and join our free DJI Mavic community today!
Sign up

AutoPilot control issue

jfboote

New Member
Joined
Jan 31, 2017
Messages
3
Reaction score
0
Age
35
So I fly Mode 1 (flew planes for years) which means my throttle is on the right stick.

When I load up and fly around with AutoPilot the controls are the same, however, when I engage Cruise Mode the throttle gets mapped to the LEFT stick and the right stick has pretty much zero control of the aircraft.

Does anyone know of or have this issue, or do you know of a fix? I have been trying to contact Autoflight but they have been slow to respond.

I appreciate any answers.

Cheers,
Julian
 

jfboote

New Member
Joined
Jan 31, 2017
Messages
3
Reaction score
0
Age
35
Just happens in Cruise Mode?
Have you tried the other combined modes?
No I haven't tried any of the other combined flight modes yet, but this is still an unusual outcome. Why does throttle get mapped to the left stick once the flight mode in engaged, and why do I have little control of the aircraft. The left stick has full control of throttle (even though it should be right stick) and left stick full left/right/forwards/back had little effect on the aircraft.
 

BrooklynFlyer

Well-Known Member
Joined
Nov 15, 2016
Messages
247
Reaction score
110
Location
Brooklyn, NY
I'm testing a beta version, although I have not been able to fly as much as I would like.

I use all default settings and I have not had any trouble. I am usually shocked at how well it works, although I am by no means a power user (though I aspire to be, hopefully in the spring)
 

Watty

Well-Known Member
Joined
Oct 18, 2016
Messages
61
Reaction score
36
Age
50
Been finding with 3.9 and the 4.0 beta, when I engage cruise mode, it's almost like the Mavic is in atti mode and drifts with the wind. When I counter the drift, the motors produce an fast oscillating noise like the gains are set too high. Anyone else seeing this?
 

jfboote

New Member
Joined
Jan 31, 2017
Messages
3
Reaction score
0
Age
35
This issue still is not resolved, however I now know it’s because Autologic have only included Mode 2 controls in the computer controlled flight modes. So any Mode 1 pilots (throttle on right stick) will find the contols switch to Mode 2 when engaging a flight mode such as ‘Cruise Mode’.

I have emailed Autologic multiple times and they have said they have added it to the queue for the developers to look at, however it is unlikely to get included.

Pretty crap if you ask me