DJI Mavic, Air and Mini Drones
Friendly, Helpful & Knowledgeable Community
Join Us Now

DJI GO app missing Mavic Pro..GROUNDED!

Spondon

Member
Joined
Nov 13, 2016
Messages
13
Reactions
1
Age
62
I received my Mavic Pro back from warranty work and I'm having trouble linking my RC to the aircraft...and the DJI GO app no longer contains the DJI Mavic Pro as a device choice.

Anyone else having this issue?
 
You need to install DJI GO 4.
 
I received my Mavic Pro back from warranty work and I'm having trouble linking my RC to the aircraft...and the DJI GO app no longer contains the DJI Mavic Pro as a device choice.

Anyone else having this issue?

Is linking the problem?

 
As of the March 23, DJI GO 3.1.6 update DJI removed support for Mavic Pro and Phantom 4 from the regular GO app. Now requiring everyone to use the newer GO4 app instead.
 
Looks like I'm linked.. Now I have a firmware update to do and I should be good! Thanks everyone...I'll let you know if I have any more trouble.
 
Also works with no problems on my ipad mini 2,
Strange indeed. Doing some reading and it seems to 'hit and miss' with the Mini 2.

I'm assuming I should have D/L'd the app prior to the update and it would have worked. Now it just won't D/L from the App Store.

I can connect with Litchi. However my firmware versions no longer match. I'm thinking I have to roll back the firmware and reinstall with the iPad connected.
 
Strange indeed. Doing some reading and it seems to 'hit and miss' with the Mini 2.

I'm assuming I should have D/L'd the app prior to the update and it would have worked. Now it just won't D/L from the App Store.

I can connect with Litchi. However my firmware versions no longer match. I'm thinking I have to roll back the firmware and reinstall with the iPad connected.

Are you using the latest iOS 10.3?

Edit: I just looked at the specs in the App Store, and it says as long as you're using iOS 9 .0 you're fine, and the iPad 2 mini is still listed as a supported device.
 
Just last week, I wiped my mini 2 and reinstalled just the apps necessary for flying (DJI go 4, Litchi, etc.....) as I decided to dedicate this iPad mini for flying only. I had no issues reinstalling the go 4 app. Could it possibly be you don't have a "2"? Is it a Retina display model?
 
I have read some where that there is an option in the app store to reload old apps on the ipad ,I am sure that I read it and not dreamt it, there was also someone on the dji site that had the same problem, but when they checked their ipad it was a mini 1 which was no longer supported
 
Last edited:
Looks like my Mini is older than I thought. Time for an upgrade.

Thanks for all the responses... greatly appreciated.
 
Lycus Tech Mavic Air 3 Case

DJI Drone Deals

New Threads

Forum statistics

Threads
130,019
Messages
1,548,426
Members
159,072
Latest member
getarq